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Part Counting Application Guide
Overall Equipment Effectiveness (OEE)

Background 
Banner Engineering’s Wireless part counting application enables LEAN 
initiatives by providing the ability to measure and analyze OEE metrics of 
availability, performance, and quality to compare how your process/machine 
is performing against an ideal state.

Value
•	 Increases uptime and capacity use
•	 Improves process awareness – Immediate feedback on process 

states and error conditions 
•	 Reduces cost of quality – Timely corrective actions = improved yields
•	 Optimizes machine throughput – Reducing cycle time lowers 

production cost
•	 Standardizes the method for productivity for benchmarking/

continuous improvement
•	 Uses IIOT –  Real-time monitoring, data collection, and alerts for better decision making

Banner OEE Solution – 
Wirelessly track parts flow

•	 Availability - Tracking of process/machine availability. 
•	 Performance – Identify root causes for non-optimal productivity 
•	 Quality – Identify continuous improvement opportunities

How Banner Solves
•	 Wireless sensors count the inputs and outputs and send the counts to the DXM Controller. The DXM Controller runs a script to calculate 

OEE based on known parameters. Data can be sent to a host system or directly to a website for IIoT.
•	 DXM Controller uses part count rates to determine process flow. Current production states, such as Running, Slow, Stopped, Jammed, 

and Starved, give feedback to troubleshoot performance issues.

A PDF version of this Application Guide is available at https://goo.gl/YBLyBC
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Application Components
Model Description

Up to 8 Pairs of Wireless Q45 Sensor Nodes:
DX80N9Q45D or DX80N9Q45LP (900 MHz)
DX80N2Q45D or DX80N2Q45LP (2.4 GHz)

Sure Cross Wireless Q45 Sensor – Diffuse and/or Retroreflective

DXM100-B1C1R1 (900 MHZ) or DXM100-
B1C1R3 (2.4 GHz)

DXM100 Wireless Controller with Cellular module 
Select either 900 MHz or 2.4 GHz ISM radio to match the Q45 Sensor pairs; the C1 models are only 
necessary if a cellular module is desired

Features and Benefits
OVERALL EQUIPMENT EFFECTIVENESS 
(OEE) CALCULATIONS

Calculates OEE actual vs. user defined ideal state answering: “How close is system to ideal state”. 
Instantaneous and averaged OEE parameters calculated including Availability (A), Performance (P), 
and Quality (Q).  OEE = A × P × Q

PART COUNTING Use up to 8 pairs of battery-powered Wireless Q45 Nodes for part counting up to 960 parts/min

TRACK PARTS/MIN RATES Calculates parts/min rates for each counting pair of sensor nodes

MONITORING MACHINE STATE By counting in/out -  Determines machine states: Running, Slowed, Stopped, Jammed, or Starved 
based on part rates and user configurable settings. Track times and counts of error states.

EXTENDED ERROR ALERTS User configurable parameters to trigger alerts when error states are active for extended periods 

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on specific events

WIRELESS SENSORS No additional control or power wires to install

IIOT - CLOUD MONITORING Push data to Cloud Webserver or PLC for remote viewing, alerting, and logging

EXPANDABILITY Ability to easily add additional wireless nodes to monitor other operations

Getting Started
The following guide demonstrates how to bind the Wireless Q45 Sensor Nodes to the DXM Controller and load a preconfigured XML file and 
script. The application uses up to eight pairs of part counting Nodes to monitor incoming and outgoing part counts of a machine/process to 
determine status and OEE metrics. 

The XML file requires only minor modifications to be customized for any site.

Step 1: Bind the System and Assign Addresses
Binding the Q45s to the DXM100 establishes a secure connection and assigns a specific network address to each Node in the wireless 
network. The Q45s work in pairs. On each machine or process, this example uses Node 1 for incoming part counts and Node 2 for outgoing 
part counts. Label the Q45s with their Node IDs after they are bound.

1.	 Apply power to the DXM Controller. 
2.	 On the DXM Controller: Use the arrow buttons to select the ->ISM Radio menu. Push Enter. 
3.	 To bind Node 1: 

a.	 Select ->Binding to >1 and push Enter. 

b.	 On Node 1: Open the access door.

c.	 Set DIP switch 3 to the ON position.

d.	 Triple-click the button to begin the binding procedure. The green and red LEDs flash 
four times to indicate a successful binding. This Node binds to the DXM Controller as 
Node ID 1.

e.	 Label the device for future reference using the included label.

1 2 3 4

5

6

1. Button
2. Red LED (flashing) indicates a radio link error with the Gateway.
3. Green LED (flashing) indicates a good radio link with the Gateway.
4. Amber LED for Alignment or Test Mode. Indicates sensor function (optical 
sensor models) or when input 1 is active (dry contact models). The amber LED 
is not used during normal operation.
5. Excess gain potentiometer. Turn clockwise to increase the gain.
6. DIP switches
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4.	 To bind Node 2: 
a.	 On DXM Controller menu screen, click Back 

b.	 Change the DXM Controller menu to Bind to > 2 and press Enter. 

c.	 Repeat steps 3b-e. The Node binds to the DXM Controller as Node ID 2.
5.	 After binding all devices: On the DXM Controller, press Back to return to the main menu. To bind more devices, repeat the previous 

steps as necessary. 

Step 2: Configure the System
To customize the system to an actual application, you may need to make some basic modification to the template files. There are three files 
uploaded to the DXM: the XML file sets the DXM’s initial configuration, the Data file (.dat) is used to define custom OEE and part counting 
parameters, and the ScriptBasic file (.sb) uses all the incoming data for part counting and OEE calculations (creates a reset function via the 
DXM display for timer and count resets, and organizes the information in logical and easy to find registers in the DXM).

1.	 Download the preconfigured files. (https://goo.gl/wpttfr)
2.	 Extract the ZIP files into a folder on your computer. Note the location where the files were saved.
3.	 Connect the DXM Controller, via the USB cable supplied, to a computer containing the downloaded DXM Configuration Software.
4.	 Launch the software and load the “Part Counting OEE…” XML file by going to the File > Open menu and choosing the configuration 

files.
5.	 Connect the software to the DXM Controller:

a.	 Go to the Device > Connection Settings screen. 

b.	 Select Serial, then select the COM port that the USB cable is plugged into. 

c.	 Click Connect. (If you are unsure which COM port you need, and multiple appear, attempt to connect to each one of them 
until you are successful).

6.	 Upload the “Part Counting OEE…” script file: 
a.	 Go to Settings > Scripting screen. 

b.	 Click Upload Script.

c.	 Select the uploaded file in the window to the right of the Upload Script button. 

d.	 Click Add Selected to Startup so the DXM runs this script every time it restarts.
7.	 Save the XML file using the File > Save menu. (Save the XML file any time the XML has been changed because the tool does not 

autosave.)

https://goo.gl/wpttfr
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Set up the OEE Parameters
1.	 Open the provided SbFile1.csv file in Excel. 
2.	 Set system information for each Node pair being used in the system, if the information is different than the defaults:

a.	 Report Time (recommended to stay at or above 60 seconds) – The time (seconds) that the Nodes report part counts back 
to the DXM

b.	 Scale Factor – Ratio of parts coming in to parts going out. For example, if 10 parts go into the process and get packaged 
into a single part going out, the Scale Factor is 10).

c.	 Ideal IN Parts/Min – User defined as the ideal parts per minute rate of parts entering the process for the Performance 
calculations.

d.	 Ideal RUN Time/Min – User defined as the ideal average running time in seconds of the process per minute for the 
Availability calculations. For example, if in an eight-hour period the ideal run time is 6 hours, this would be 6/8 × 60 seconds 
= 0.75 × 60 seconds = 45 seconds.

e.	 RUN Parts/min – Rate of parts/min for IN and OUT that would be considered “running” when at or above.

f.	 STOPPED Parts/min – Rate of parts/min for IN and OUT that would be considered “stopped” when below. Any value in 
between running and stopped is considered “slow”.

g.	 Stop Reports – Number of consecutive reports required before the system indicates a “stopped” condition.

h.	 Extended Time – Number of seconds before an error state (Stopped, Jammed, or Starved) is reported as an extended 
condition.  

i.	 Starved Threshold – Rate of parts/min IN that when below is considered a “starved” condition after three consecutive 
reports.

j.	 Jammed Threshold – Percentage of Parts OUT vs Parts IN rates that would triggered a “jammed” condition after three 
consecutive reports. For example, setting the Jammed Threshold to 120 means a “jammed” condition occurs when the 
Parts OUT rate is 120% or more of the Parts IN rate.

3.	 Select Save As… on the CSV file with the name “SbFile1.dat” (including the quotation marks before and after the name) in the Save 
As file name box. This is necessary to generate the .dat type file.

4.	 Upload the “SbFile1.dat” data file by going to the Settings > Scripting screen. 
a.	 Click Upload Script.

b.	 Change the file type just above the Open/Cancel buttons in the popup to “All Files (*.*)”.

c.	 Select the file.

This file can be modified at any time and can be scheduled to take effect at specific times. Refer to the Additional Features section for 
instructions on how to do this.
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Optional Steps: Customize the XML file
1.	 On the DXM Configuration Tool: Go to the Local Registers > Local Registers in Use screen.
2.	 Enter a name for the Part Counting Sensor registers in the Register Name field. 

3.	 To display the station status, count, or timer on the website set the Web field to Read and set Cloud Reporting to ON for each 
stations’ information piece (presence, timer, count, etc.) that you would like to appear on the website.

4.	 To display the registers for each part counting pair on the website, change the cloud permissions.
a.	 On the Modify Multiple Registers screen, select Change in the drop-down list 

next to Cloud Permissions.

b.	 In the drop-down list to the right, select Read for Cloud Permissions.

c.	 Set the Starting Register to 1 and the Ending Register to the value equal to 40 
× the number of stations in the system (Example: Set register to 320 for 8 part 
counting sensor pairs).

d.	 Click Change Registers.
5.	 Configure to receive email or text alerts based on an Action Rule.

a.	 Go to the Action Rules screen and expand any rule using the arrow next to the 
rule OR create a new action rule by clicking Add Threshold Rule.

b.	 Click on the arrow next to Email/SMS on State Transition.

c.	 Select the recipient of the SMS and/or email upon the action rule becoming true. 
(Setting up the emails or SMS phone numbers to receive messages will be in the 
next section of the guide.)

In the example shown, both SMS Recipient 1 and 2 and Email Recipient 1 and 2 will receive a 
message when the action rule meets its criteria.
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Set up the Ethernet or Cellular Connection
By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data registers to 
a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and data plan. This 
section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1.	 If the DXM will text, email, or push to the cloud webserver, set up the push interface.
a.	 On the DXM Configuration Tool, go to the Settings > Cloud Services screen.

b.	 Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list. Selecting Cell requires cellular module be 
installed in DXM Controller and a wireless plan set up for sending data.

2.	 The Cloud Push Interval determines how often the DXM pushes the current status data to the webserver. By default, this interval is 
set to zero and should not be changed. If data is being pushed to the cloud, set the Cloud Push Interval to 00:15:00 (15 minutes). 

3.	 Set up the email and text messages. Expand the Email Recipients and SMS Recipients to enter up to 10 email addresses and 10 
phone numbers, along with a custom message.

a.	 Go to the Settings > Mail and Messaging screen.

b.	 All SMTP fields should remain set to their default values, except the Password field (unless using customer’s own desired 
SMTP server). Enter “9Hp7+anXhQ” into the password 
field.

c.	 Click Send SMTP Password.

d.	 Click Yes when asked to reboot the device.

Step 3: Save and Load the XML File to DXM
When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1.	 Save the file by going to the File > Save menu.
2.	 Load the file onto the DXM by going to the Device > Send XML Configuration to DXM menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the 
Application Status indicator in the status bar.

If the Application Status indicator is red, close and restart the DXM Configuration Software, unplug and re-plug in the USB cable and 
reconnect the DXM to the software. If the Application Status indicator is green, the file upload is complete. If the Application Status 
indicator is yellow, the file transfer is in progress.
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Step 4: Conduct a Site Survey
Conduct a Site Survey to verify the wireless connection between your Q45s and the DXM.

1.	 On the DXM: Use the arrow buttons to select the ISM Radio menu. Push Enter.
2.	 Select the Site Survey submenu, and press Enter.
3.	 Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
4.	 When you are finished running the site survey, press Back twice to return to the main menu.

Forgetting to exit the site survey causes system issues and reduces the battery life of the Q45Us.

Step 5: Push Information to the Cloud
The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to the cloud and displayed on a 
website. To enable this capability for remote monitoring and alarms settings, modify the XML file.

The Banner website for storing and monitoring the system's data is https://bannercds.com.

1.	 Connect the DXM to a computer with the DXM Configuration Software.
2.	 Launch the software and connect to the DXM.
3.	 Load the saved XML file.
4.	 Go to the Settings > Cloud Services screen.
5.	 Visit the website and log into an existing account or register a new account.
6.	 Click + New Site. Name your site.
7.	 Highlight and copy the Site ID.
8.	 On the DXM Configuration Software: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.
9.	 Save the XML file (File > Save).
10.	 Upload the file to the DXM (Device > Send XML Configuration to DXM).
11.	 On the website: Click Options on the row of the newly created site. Select XML Config and select the XML file that was just saved/

uploaded to the DXM.
12.	 Click Save to complete the connection to the website.

This creates continuity between the site created on the website with the DXM used in the field. The DXM pushes data to the website, which 
can be viewed at any time. Refer to the Banner Cloud Data Services Instruction Manual to review all the features available for monitoring, 
comparing data, and establishing warnings/alarms on the website.

To access a demo version of the website please contact your local Banner distributor and follow the instructions in the technical note: 
Connecting to the Banner Cloud Data Services Demo Site for modified instructions on how to send data to the demo site.

https://data.sensonix.net/
http://info.bannerengineering.com/cs/groups/public/documents/literature/178337.pdf

http://info.bannerengineering.com/cs/groups/public/documents/literature/b_4476257.pdf
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Additional Features
Resetting the Timer and Counts
Each pair of part counting sensors in the system has a reset register that is available on the face of the DXM’s LCD and via the website. 
Setting this register to 1 resets all the counts and timers on that particular Station.

Resetting from the DXM
1.	 On the DXM: Use the arrows to select Registers. 

The registers are labeled Reset X (where X is the sensor pair you want to reset). This resets all 40 registers associated with that 
counting pair. There is also a Reset All register available.

2.	 Select the appropriate register to reset.
3.	 Click Enter.
4.	 Change the value to 1 then click Enter three times. 

The reset register automatically returns to zero after the register(s) reset.

Resetting from the Website
1.	 Go to the Dashboard > Sites screen.
2.	 Click Options for the site where the particular sensor pairs exists. 
3.	 Click the Update tab in the pop-up window that appears. From the Type drop-down list, select Register.
4.	 From the Register Name drop-down list, select the sensor pair ID you want to reset.
5.	 Enter 1 into the Value field and click Queue.
6.	 Repeat steps 4 and 5 for each station that needs to be reset or use the Reset All register following steps 4 and 5.

When the next data push occurs, the chosen units reset. The reset registers automatically return to zero after the register(s) reset.

Setting and Scheduling New User-Configurable Parameters
A new file (SbFile1.dat) can be created and added to the DXM at anytime after the device is initially setup.  This allows a customer to make 
changes to the lines parameters to properly calculate the OEE statistics if the line is reconfigured or a different job is being run on that shift. 
Once the file is loaded, the system must be “Initialized” either immediately or by setting up a schedule in the XML. Follow the instructions on 
resetting an individual sensor pair or resetting all sensor pairs if desired to zero out previous data following the addition of the new parameters.

Adjust parameters and initialize
1.	 Create a new SbFile1.dat with new parameters and upload it to the DXM by following the second part of Step 2 of this guide.
2.	 To initialize the system based on these new parameters, use one of the following three methods:

On the DXM: Click Registers and select Initialize. Click Enter and change the value from 1 to 0 and hit Enter until you return to the 
Registers menu.

In the DXM Configuration Tool: While connected to the DXM, go to the Register View screen. On the right side of the screen enter 
841 as the Starting Register, verify 0 is the value, and click Write Registers.

On the Sensonix Web Services website: click Update Device for the site where the particular sensor exists. Select Register from the 
Type drop-down list. In Register Name select Initialize. Enter a 0 into the Value field and click Queue.

Schedule parameters to take place
1.	 Create a new SbFile1.dat with new parameters and upload it to the DXM following the second part of Step 2 of this guide.
2.	 In the DXM Configuration Tool, go to the Scheduler > One Time Events screen.
3.	 Expand the Schedule Initialize event.
4.	 Adjust the parameters for the date and start time to initialize the device and put a 1 as the Start Value.
5.	 Check the box next to End Value and place a 0 for the End Value and set the date and time to 1 minute after the start time and 

date.
6.	 Save the XML by clicking File > Save and upload the XML file to the DXM. Note that sending the XML to the DXM causes a reboot. 

The data in the DXM is erased, so perform this step between work periods.
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Configure Time-Stamped Logging
To set up time-stamped logging, follow these steps.

1.	 On the DXM Configuration Software: Go to the Local Registers > Modify Multiple Registers screen.
2.	 Click Reset Form.
3.	 From the SD Card Logging drop-down list, select Change.
4.	 Select Log 1 in the drop-down list that appears to the right.
5.	 Set the Starting Register to 1 and the Ending Register to a value equal to 40 × Number of sensing pairs in the system. (For 

example, set the Ending Register to 320 for eight pairs of sensors). 
6.	 Click Change Registers.

Retrieve a Log File
Follow these steps to save a log file to your computer.

1.	 On the DXM Configuration Software: Go to the Settings > Logging screen.
2.	 Click Refresh List.
3.	 In the Log File Management window, select the file to save.
4.	 Click Save Selected to save the file to a folder on your computer.

Local Registers
Local Register # Description

Counter Node Info

1 + 40 × (N − 1) Part Count IN

2 + 40 × (N − 1) Part Count OUT

3 + 40 × (N − 1) Part Count Differential between IN and OUT

4 + 40 × (N − 1) Counter State IN

5 + 40 × (N − 1) Counter State OUT

6 + 40 × (N − 1) Parts per minute IN

7 + 40 × (N − 1) Parts per minute OUT

Running
8 + 40 × (N − 1) Running State

9 + 40 × (N − 1) Running Time Total

Slowed
10 + 40 × (N − 1) Slowed State

11 + 40 × (N − 1) Slowed Time Total

Stopped

12 + 40 × (N − 1) Stopped State

13 + 40 × (N − 1) Extended Stop State

14 + 40 × (N − 1) Stop Time Total

15 + 40 × (N − 1) Stop Count Total

16 + 40 × (N − 1) Average Stop Time

Jammed

17 + 40 × (N − 1) Jammed State

18 + 40 × (N − 1) Extended Jam State

19 + 40 × (N − 1) Jammed Time Total

20 + 40 × (N − 1) Jammed Count Total

21 + 40 × (N − 1) Average Jam Time

Starved

22 + 40 × (N − 1) Starved State

23 + 40 × (N − 1) Extended Starved State

24 + 40 × (N − 1) Starved Time Total

25 + 40 × (N − 1) Starved Count Total

26 + 40 × (N − 1) Average Starved Time
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OEE Instantaneous

27 + 40 × (N − 1) OEE Calculation Instantaneous

28 + 40 × (N − 1) Availability Calc Instantaneous

29 + 40 × (N − 1) Performance Calc Instantaneous

30 + 40 × (N − 1) Quality Calc Instantaneous

OEE Averages

31 + 40 × (N − 1) OEE 60 minute Moving Average

32 + 40 × (N − 1) Availability 60 minute Moving Average

33 + 40 × (N − 1) Performance 60 minute Moving Average

34 + 40 × (N − 1) Quality 60 minute Moving Average

Connection Error 35 + 40 × (N − 1) Connection Error Report of either node in the sensing pair (0/1)

Background Registers 
Used by Script

321–328 Reset registers for each sensing pair

329–344 Connection Status for each node

410–425 Part Count Rate Timers

426–465 Machine State Timers

467–474 Report Timers

475–482 Total Timers

500–515 Sensor State (On/Off)

840 Reset All

841 Initialize

842 Schedule Initialize

843 Read Trigger

Where N represents the Part Counting Pair ID.

Glossary of Terms Used
RUNNING–Process state when parts/min rate IN and OUT exceeds the Parts/min RUN threshold.

SLOW–Process state when parts/min rate IN or OUT is less than the Parts/min RUN and greater than the Parts/min STOPPED. Also 
considered slow if the parts rate is below the STOPPED threshold but for less than the user defined report cycles.

STOPPED–Process state when parts/min rate IN and OUT is less than the Parts/min STOPPED threshold for a length of time determine by 
Stop Reports × Report Time.

JAMMED–Defined as more parts coming in than coming out of the process. Will not trigger until the condition is met for more than two report 
cycles. Jammed Threshold allows for some built-in variance allowance. Default: 120%.

STARVED–Defined as part rate IN being below user defined Starved Threshold for 2+ report cycles.

Overall Equipment Effectiveness (OEE)–Availability (A) × Performance (P) × Quality (Q) = OEE

AVAILABILITY (A)–(Running time + Slow time per min) ÷ (Ideal Run Time per min)

PERFORMANCE (P)–(Parts per minute IN) ÷ (Ideals parts per min IN)

QUALITY (Q)–(Parts per minute OUT) ÷ (Parts per minute IN)


