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IO-Link is an open standard serial communication protocol that allows for the bi-directional exchange of data from IO-Link-
supported devices, such as sensors, that are connected through IO-Link.

Advantages to an IO-Link system include standardized wiring, remote configuration, simple device replacement, advanced 
diagnostics, and increased data availability. Because IO-Link is an open standard, the devices can be integrated in almost 
any fieldbus or automation system.

An IO-Link system consists of an IO-Link master and an IO-Link device such as a sensor, lighting product, IO-Link hub, or 
actuator.

The functions and parameters of the IO-Link devices are represented in a device description file (IODD). IODD files contain 
information about identification, device parameters, process and diagnostic data, communication properties, and other 
details. The IODD files for Banner IO-link devices can be downloaded for free on www.bannerengineering.com.

IO-Link Systems
At least one IO-Link master and one IO-Link device are required for IO-Link communication.

The IO-Link master and IO-Link device are connected using a 3-wire standard unshielded cable. The IO-Link master 
establishes the connection between IO-Link device and the higher-level control system. An IO-Link master can have several 
IO-Link ports, and only one IO-Link device can be connected to each port.

IO-Link hubs such as Banner's R90C-4B21-KQ or IO-link converters make it possible to integrate devices without an IO-Link 
output in automation systems via IO-Link.

IO-Link OverviewChapter 1 

http://www.bannerengineering.com
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IO-Link map

IO-Link Port/Operating Modes
The operating mode can be configured for any port on the IO-Link master. The following modes can be used:

Deactivated
Use deactivated mode for any unused IO-link master ports if a 
device is not connected.

IO-Link Manual
The IO-Link master only connects IO-Link devices that have a 
certain vendor ID and device ID (1: IOL_MANUAL).
This mode is also required to for the Backup and Restore or 
Restore function.

IO-Link Autostart
The IO-Link master connects to every connected IO-Link 
device (2: IOL_AUTOSTART).

Digital Input
The IO-Link port functions as a standard digital input (3: DI_C/
Q).

Digital Output
The IO-Link port functions as a standard digital output (4: 
DO_C/Q).

Combining IO-Link Devices with Different Specifications
Any combination of masters and devices is possible. However, if IO-Link devices of a different IO-Link specification are 
combined, note that:

Only IO-Link v1.0 devices can be operated on the IO-Link v1.0 masters
IO-Link v1.0 and v1.1 devices can be operated on the IO-Link v1.1 masters

IO-Link devices with IO-Link specification V1.0 do not support backup and restore features (data storage).
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Banner's DXMR90-4K IO-Link Master consolidates data from multiple sources to provide local data processing and 
accessibility for host systems as a platform for the Industrial Internet of Things (IIoT).

The DXMR90-4K IO-Link Master 4-port IO-link device serves as the gateway to connect up to four IO-link devices including 
sensors, lighting products, IO-link hubs, and more. The DXMR90-4K IO-Link Master can have multiple configurations and 
includes a model number label on the housing. Use this model number to identify which boards are included in your 
controller.

The DXMR90-4K contains four IO-link ports, allowing for concurrent communication to up to four IO-Link devices. Data is 
collected into the internal logic controller to facilitate edge processing, protocol conversion to Industrial Ethernet, Modbus/
TCP, and pushing information to web servers. In addition to IO-Link devices, the IO-Link master can transmit up to eight 
discrete signals using pin 2 or pin 4 of the IO-link master ports.

The configurable IO-link master device works with IO-link devices and allows for quick deployment of IO-link data to Ethernet, 
PROFINET, Modbus TCP, and Modbus RTU networks.

Local control or connectivity with automation protocols, including EtherNet/IP, PROFINET, Modbus/TCP, and Modbus 
RTU(1)

Logic processing and problem-solving capable of deploying solutions to process and control data from multiple 
devices
Compact housing saves space and weight compared to traditional "block" style form factors
IP67 housing simplifies installation in any location by eliminating the need for a control cabinet
Consolidate cable runs to minimize cabling and associated weight, especially in weight-critical applications such as 
robotics
Flexible and Customizable—Expanded internal logic controller with action rules and ScriptBasic programming

Logic Controller
Program the DXMR90-4K's logic controller using action rules 
and/or ScriptBasic programming languages, which can 
execute concurrently. The control functions allow freedom 
when creating custom sensing and control sequences. The 
logic controller supports the Modbus protocol standards for 
data management, ensuring seamless integration with 
existing automation systems. File password protection is an 
option.

Action Rules
Thresholds (IF/THEN/ELSE) with timers, minimum 
on/off time
Math/Logic Rules (arithmetic and bitwise operators)
Control Logic (logical operators and SR/T/D/JK flip 
flops)
Trending (multiple averaging filters)
Tracking (counts, on/off times)

Product OverviewChapter 2 
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Push data on conditions
Programming Language—ScriptBasic to create variables, 
arrays, functions, loops, IF/THEN/ELSE, logical and arithmetic 
operators, API commands, register access, string functions 
and operators, time commands
Scheduler

Time/calendar-based events
Holiday skips
One-time events
Dynamic scheduler updating
Astronomical clock

Push to the Cloud
Register Mapping

Cyclical Read rules from wireless devices or local 
wired Modbus devices that include optional scaling, 
error conditions, and the ability to activate a read rule
Cyclical or Change of State Write rules to local wired 
Modbus devices with scaling
Modbus/TCP Controller/Primary Read or Write rules 
for external devices on the network

Wired Connectivity
Ethernet: Modbus/TCP (client/server), Ethernet/IP, or 
PROFINET

User Interface
API Interface—Host Initiated control and Web service 
integration

Models
Model Ethernet Connection IO-Link Master Connections Other Connections

DXMR90-4K One 5-pin D-code M12 
female Ethernet connector

Four 5-pin M12 female 
connections for IO-Link 
master connections

One 5-pin M12 (Port 0) male connector for incoming power 
and Modbus RS-485, one 5-pin M12 female connector for 
daisy chaining Port 0 signals.

Automation Procotols
The DXMR90-4K IO-Link Master supports the following automation protocols.

EtherNet/IP™
By default, EtherNet/IP is enabled. Configure the DXMR90-4K
Local Registers as EtherNet/IP input or output registers using 
the DXM Configuration Software. A single register can only be 
set as either an EtherNet/IP input or output register.
EtherNet/IP registers are limited to 228 read registers set as 
E/IP Originator to DXM and 228 write registers set as DXM to 
Originator

Modbus® RTU
Modbus RTU port (port 0) is used by a host system to access 
the DXMR90-4K as a server device. The server Modbus RTU 
port allows access to all the internal local registers 
concurrently with the client RTU port. Port 0 can be configured 
as a Modbus client port using the DXM Configuration 
Software but is defined as a server port by default.
Configure to a client port using the DXM Configuration 
Software to allow data access to other Modbus devices like 
the 4-Port IO-Link to Modbus Client R90C-4K-MQ or other 
Modbus accessible server devices.

Modbus® TCP/IP
A host system acting as a Modbus client can access the 
DXMR90-4K using the Modbus TCP/IP protocol over 
Ethernet. Standard Modbus TCP port 502 is used by the 
DXMR90-4K for all Modbus TCP/IP requests.
All internal local registers are available to the host system 
concurrently with Modbus TCP.
By default, the DXMR90-4K is configured as a Modbus TCP/
IP server.

PROFINET®
By default, PROFINET is disabled on the DXMR90-4K. To 
enable and configure the DXMR90-4K for PROFINET 
communications, use the DXM Configuration Software.
The DXMR90-4K uses fixed slot sizes and locations in the 
Local Registers for the input and output values. Supported 
module sizes are 64, 128, 256, and 512 bytes, which range 
from 32 to 256 in the DXM's Local Registers.

Modbus® is a registered trademark of Schneider Electric USA, Inc. IO-Link® is a registered trademark of PROFIBUS 
Nutzerorganisation e.V. PROFINET® is a registered trademark of PROFIBUS Nutzerorganisation e.V. EtherNet/IP™ is a 
trademark of ODVA, Inc. All other trademarks and registered trademarks cited are the property of their respective owners. 



Product OverviewDXMR90-4K IO-Link Master Product Manual

27-Feb-25page 8 of 44 © Banner Engineering Corp. All rights reserved. 
www.bannerengineering.com

DXMR90 Dimensions
All measurements are listed in millimeters, unless noted otherwise. The measurements provided are subject to change.

DXMR90-4K dimensions

16 mm
[0.63”]

32.3 mm
[1.27”]

6x M12 x 1 (Female)

121.7 mm
[4.79”]

16.3 mm
[0.64”]

20 mm
[0.79”]

20 mm
[0.79”]

20 mm
[0.79”]

40 mm
[1.57”]

4.5 mm dia
[0.18”]

63.5 mm
[2.5”]

50.5 mm
[1.99”]

M12 x 1
(Male)

8 mm
[0.32”]

12.3 mm
[0.48”]

32.3 mm
[1.27”]
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Apply Power to the Controller
Follow these instructions to apply 12–30 V DC power to the DXMR90-4K using a wall plug.

Required equipment:
DXMR90-4K IO-Link Master
PSW-24-1 Wall plug power supply; 24 V DC, 1 A (or equivalent 24 V DC M12 power supply)

Wiring
DXMR90-4K IO-Link Master ports

Ports 1-4 female connector

Port 1–4 5-pin M12 female connector Pin Wire Color Description

2

3
4

1

5

1 Brown (bn) 18 V DC to 30 V DC

2 White (wh) I/Q (digital in-out)

3 Blue (bu) DC common (GND)

4 Black (bk) C/Q (communications/digital in-out)

5 Gray (gy) No connection/not used

Quick Start GuideChapter 3 

Connect the PSW-24-1 power supply to the male M12 connector on the DXMR90-4K, Port 0.1. 

Plug in the PSW-24-1 wall plug power supply.2. 
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Port 0 male connector

Port 0 5-pin M12 male connector Pin Wire Color Description

1

4
53

2

1 Brown (bn) 18 V DC to 30 V DC

2 White (wh) RS485 / D1 / B / +

3 Blue (bu) DC common (GND)

4 Black (bk) RS485 / D0 / A / -

5 No connection/not used

Port 0 female connector

Port 0 5-pin M12 female connector Pin Wire Color Description

2

3
4

1

5

1 Brown (bn) 18 V DC to 30 V DC

2 White (wh) RS485 / D1 / B / +

3 Blue (bu) DC common (GND)

4 Black (bk) RS485 / D0 / A / -

5 No connection/not used

D-coded industrial Ethernet connector

5-pin D-code female Industrial Ethernet 
Connector Pin Wire Color Description

1

4 3

2

5

1 Black (bk) +Tx

2 Red (rd) +Rx

3 Green (gn) –Tx

4 White (wh) –Rx

5 No connection/not used

Configuration Instructions
DXM Configuration Software
Configure the DXMR90-4K using the configuration software. Use this software to customize your configuration and to 
process data from the Controller.

Download the latest version of all configuration software from http://www.bannerengineering.com. For more information on 
using the DXM Configuration Software, refer to the instruction manual (p/n 209933).

http://info.bannerengineering.com/cs/idcplg?IdcService=GET_FILE&dDocName=b_4496867&RevisionSelectionMethod=Latest&Rendition=web
http://www.bannerengineering.com
http://info.bannerengineering.com/cs/idcplg?IdcService=GET_FILE&dDocName=209933&RevisionSelectionMethod=Latest&Rendition=web
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Overview of the configuration software features

DXM Configuration Software
Local Registers

Register Mapping

Action Rules

Scheduler

ScriptBasic

System
Settings

Register
View Utility

EthernetXML Config
File

The configuration software creates an XML file that is transferred to the DXM using an Ethernet connection. The DXM can 
also receive the XML configuration file from a Web server using an Ethernet connection. This configuration file governs all 
aspects of the DXM operation. The DXM Configuration Software allows the user to define parameters for the DXMR90-4K, 
then saves the configuration in an XML file on the PC.

After the configuration file is saved, upload the XML configuration file to the DXMR90-4K for operation.

IMPORTANT: The DXMR90-4K IO-Link Master comes preloaded with a default configuration XML file. You 
can download the default XML on the product page for the DXMR90-4K.

This quick start guide outlines the basic operations to set up a DXMR90-4K using the configuration software. For a more 
comprehensive explanation of features, refer to the DXM Configuration Software Instruction Manual (p/n 209933).

Configuring the DXMR90-4K Controller
This section will walk you through the method of setting up the DXM Configuration Software and communicating with a 
connected DXM device. Version 4 of the DXM Configuration Software supports multiple DXM device models, each of which 
incorporates different features.

As soon as a DXM model is connected to your computer, the software automatically detects the correct model and loads the 
appropriate screens. You may also manually select which model of DXM you are configuring if you intend to create a 
configuration file without connecting a device. This ensures that the interface and the configuration file use the correct 
features.

Not all screens are available for all models. To change to another model of DXM, go to the Select Mode screen and use the 
drop-down list to select another model. If the active configuration is incompatible with the selected model, you will be 
prompted to either proceed and wipe out the active configuration or cancel the model change and preserve the configuration.

http://info.bannerengineering.com/cs/idcplg?IdcService=GET_FILE&dDocName=209933&RevisionSelectionMethod=Latest&Rendition=web
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Opening splash screen for Traditional Setup mode

When the Select DXM Model drop-down is set to DXMR90-4K, a new network discovery table is displayed. Click Scan 
Network for DXMs to detect DXM devices on the host computer's network. Discovered DXMs are listed in the network 
discovery table. Double-click any row entry to connect to that DXM. If the DXM's IP address is already known, the standard 
TCP connection option is available below the network discovery table.

The default IP address of the DXMR90-4K is 192.168.0.1. To connect to the device, you need to be on the same subnet. You 
can do this by accessing the control panel on your PC and accessing your Network Connections properties. It is important to 
ensure that the adaptor you are connected to is within the 192.168.0.* subnet when you first connect to the DXMR90-4K IO-
link master.

Windows Network Properties settings screen

IMPORTANT: Any model of DXM may connect to the configuration software regardless of which device 
model is selected in the configuration software. Compatibility is checked before configuration files are 
uploaded to the device.
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For more information on the device registers and port settings of the DXMR90-4K IO-Link Master, refer to the IO-Link Master 
Device Register Map (p/n 229732). 

Modify Multiple Registers
Modify a range of registers from the Local Registers › Local Registers in Use › Modify Multiple Registers screen.

Select which parameter fields to modify. Most parameters have three selections.
Unchanged—no changes
Default—change to default settings
Set—modify the parameter. Other selections will appear based on the parameter.

Modify Multiple Registers screen

Set the IP Address
Follow these instructions to change the DXMR90-4K's IP address.

By default, the DXMR90-4K is set to a static IP address of 192.168.0.1. The IP address can be changed by using the DXM 
Configuration Software and updating the XML.

Save and Upload the Configuration File
After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the 
device.

Changes to the XML file are not automatically saved. Save your configuration file before exiting the software and before 
sending the XML file to the device to avoid losing data. If you select DXM › Send XML Configuration to DXM before saving 
the configuration file, the software will prompt you to choose between saving the file or continuing without saving the file.

Enter the Starting register and Ending register.1. 

Select the value to change using the drop-down list next to each value.2. 

Enter the new value in the field provided.3. 

To push register values to the web server, set Cloud Settings to Read.
If the Cloud Settings are set to Read, the web server only views data from the device and cannot write data to the 
device. If the permissions are set to Write, the web server only writes to the device and cannot read the data. If the 
permissions are set to Read/Write, the web server can read the data from the device and write to the device from the 
web.

4. 

Click Modify Registers to save and apply the changes.5. 

Launch the DXM Configuration Software.1. 

Go to the Settings › Ethernet screen.2. 

◦
◦

In the IP Address section, select Static IP or DHCP from the drop-down list.
If Static IP is selected, enter the IP address, Subnet, and Gateway address as desired.
If DHCP is selected, the IP address, Subnet, and Gateway address are grayed out and not configurable.
Changing the IP Address to DHCP can make it so the DXM cannot be reached. Before changing this to 
DHCP, you MUST have a server that is going to assign an IP Address to the DXMR90-4K.

3. 

Save your changes to the configuration file (File › Save).4. 

Upload the configuration file to your controller (DXM › Send Configuration to DXM).5. 

Save the XML configuration file to your hard drive by going to the File › Save As menu.1. 

Go to the DXM › Send XML Configuration to DXM menu.2. 

https://info.bannerengineering.com/cs/groups/public/documents/literature/229732.pdf
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Installing the DXMR90-4K
Install the DXMR90-4K to allow access for functional checks, maintenance, and service or replacement.

Fasteners must be of sufficient strength to guard against breakage. The use of permanent fasteners or locking hardware is 
recommended to prevent the loosening or displacement of the device. The mounting hole (4.5 mm) in the DXMR90-4K
accepts M4 (#8) hardware. See the figure below to help in determining the minimum screw length.

Nut
3 mm *

for minimum
engagement of
three threads

Screw Length = 16.0 mm + “X” mm + 3 mm

X

 *

16.0 mm

CAUTION: Do not overtighten the DXMR90-4K's mounting screw during installation. Overtightening can 
affect the performance of the DXMR90-4K.

◦

◦
◦

Status indicator bar

If the Application Status indicator is red, close and restart the DXM Configuration Software, unplug and re-plug 
in the cable and reconnect the DXM to the software.
If the Application Status indicator is green, the file upload is complete.
If the Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.

After the file transfer is complete, the device reboots and begins running the new configuration.
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To connect IO-Link devices on machines in industrial environments, an M12 quick-disconnect connection is typically used. 
The pin assignment according to IEC 60974-5 is the following:

Pin 1: 24 V DC
Pin 2: Switching Digital I/O (PNP only)
Pin 3: 0 V
Pin 4: Switching Digital I/O (NPN, PNP, or Push-Pull) and IO-link Communication Line

IO-Link pin assignments

1

L+

C/Q

L-

3
2 4

IO-Link Mode 
(process data)

Digital I/O (DIO) Mode 
(ON/OFF data)

DXMR90-4K IO-Link Master ports

One male M12 connection provides common power and ground to all M12 IO-Link ports. One 100 Mbps Ethernet port 
(female) uses an M12 D-coded Ethernet connection.

Modbus TCP
EtherNet/IP
PROFINET
Configuration/discovery port

Four IO-Link controller connections using female M12 connectors.

Controller Connections for the 
DXMR90-4K

Chapter 4 
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Separate IO-Link control and programmability for each connection point
Configurable SIO mode on Input 1 and Input 2 of each IO-Link port

The DXMR90-4K IO-Link Master has four Class A ports. Pin 2 on these is an additional discrete IO channel. For specific 
pinout connections, see "DXMR90-4K Wiring" on page 9.

For more information on the device registers and port settings of the DXMR90-4K IO-Link Master, refer to the IO-Link Master 
Device Register Map (p/n 229732).

Status Indicators for the DXMR90-4K
The DXMR90-4K IO-Link Master has two LED indicators for pin 2 and pin 4 for each IO-link port to provide indication visibility. 
There is also an additional amber LED indicator to indicate power to the IO-link master.

State Pin 2 Pin 4

Off

SIO input mode and 0V in

SIO output mode and the output is turned off

Pin 2 not configured

Port is disabled

SIO input mode and 0V in

SIO output mode and the output is turned off

Solid green An IO-Link device is connected

Flashing green
IO_Link autostart or manual mode,

No device is connected

Solid amber
SIO input mode and 24 V in

SIO output mode and the output is turned on

SIO input mode and 24 V in

SIO output mode and the output is turned on

Flashing amber

Solid red Electrical short Electrical short

Flashing red IO_Link manual, validation mode, and the wrong device is plugged in

Ethernet
Before applying power to the DXMR90-4K, verify the Ethernet cable is connected.

The Ethernet connection supports the DXM Configuration Software, Modbus/TCP, PROFINET, and EtherNet/IP. ScriptBasic 
also has access to Ethernet for custom programming. Use the software to configure the characteristics of the Ethernet 
connection, including the IP address. Any parameters not changeable from the menu system are configurable from the 
configuration software.

Internal Local Registers (Modbus ID 199)
The main storage elements for the DXMR90-4K are its Local Registers, which can store 4-byte values that result from 
register mapping, action rules or ScriptBasic commands.

For more information on the device registers and port settings of the DXMR90-4K IO-Link Master, refer to the DXMR90-4K 
IO-Link Master IO-Link Register Map document (p/n 229732).

Local Registers updated from Modbus and Ethernet/IP transactions are restricted to a 16-bit data value to follow the standard 
Modbus Holding Register definition.

The Local Registers defined in Action Rules must all be within the same register group. For example, an Action Rule cannot 
have inputs from an integer group with the result register defined as a floating point register. To move between integers and 
floats, use the Register Copy Rule.

Registers  Description 

12001-12845, 17001-19000   32-bit unsigned integer-based registers 

12846-12850   Special function registers (can be reset registers) 

12851-12900, 19001-20000   Non-volatile register with limited capability for permanent data storage 

Continued on page 17

https://info.bannerengineering.com/cs/groups/public/documents/literature/229732.pdf
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Continued from page 16

Registers  Description 

13001-17000 
 32-bit IEEE 754 floating point registers. Floating point values require two Local Registers to store a value. 
Floating point Local Registers are referenced on the odd-numbered register addresses: 13001, 13003, and 
13005. When using Action Rules/Read Rules, always reference the odd-numbered register addresses. 

Local Registers 12001–12845, and 17001–19000 (Internal Processor Memory, 32-bit, Unsigned)—The Local Registers are 
the main global pool of registers. Local Registers are used as basic storage registers and as the common data exchange 
mechanism. External Modbus device registers can be read into the Local Registers or written from the Local Registers. The 
DXMR90-4K, as a Modbus client or a Modbus server, exchanges data using the Local Registers. Modbus over Ethernet 
(Modbus/TCP) uses the Local Registers as the accessible register data.

Local Registers 12846–12850 (Reset, Unsigned)—These Local registers are reserved for use as Reset registers. A time 
interval can be specified in the configuration software for the DXM to reset. If the data in the register does not change within 
the user-specified time interval, the DXM resets.

Local Registers 12851–12900 and 19001–20000 (Data Flash, Non-volatile, 32-bit, Unsigned)—The top 50 Local Registers 
are special non-volatile registers. The registers can store constants or calibration-type data that must be maintained when 
power is turned off. This register data is stored in a data flash component that has a limited write capability of 100,000 cycles, 
so these registers should not be used as common memory registers that change frequently.

Local Registers 13001–17000—These Local Registers are paired together to store a 32-bit IEEE floating point format 
number in big-endian format. Registers 12001 [31:16], 12002 [15:0] store the first floating point value; registers 12003, 12004 
store the second floating point number. There are a total of 2000 floating point values; they are addressed as two 16-bit 
pieces to accommodate the Modbus protocol. Use these registers when reading/writing external devices that require Modbus 
registers in floating-point format. Since Modbus transactions are 16-bits, the protocol requires two registers to form a 32-bit 
floating point number.

Virtual Registers—The DXMR90-4K has a small pool of virtual registers that show internal variables of the main processor. 
Some register values will be dependent upon the configuration settings of the DXMR90-4K. Do not use Read Rules to move 
Virtual Local Registers data into Local Registers. Use the Action Rule > Register Copy function to move Virtual Local 
Registers into Local Registers space (12001–12850).

Modbus registers for virtual registers

Registers Definition

22001 GPS latitude direction (N, S, E, W)

GPS Coordinate Data if the DXM is configured to read an external GPS 
unit.

22002 GPS latitude

22003 GPS longitude direction (N, S, E, W)

22004 GPS longitude

22015–22016 Reboot cause (Restart Codes above) Reboot Type

22017–22018 Watchdog reset count Counter to track how many resets have been caused by the Watchdog

22025–22026 Http Push SSL Acquires
Statistical counts of connections, disconnections and forced disconnects 
when the DXMR90-4K creates a connection using SSL/TLS (Encrypted 
connections)

22027–22028 Http Push SSL Releases

22029–22030 Http Push SSL Forced Releases

22031–22032 Http Push Attempts
Statistical counts of connections, disconnections and forced disconnects 
when the DXM controller creates a connection using HTTP non-encrypted22033–22034 Http Push Successes

22035–22036 Http Push Failures

22037–22038 Http Push Last Status

Last DXMR90-4K push status
0 = Initial state, no push attempt as finished yet
1 = Attempt complete
2 = Attempt aborted

22055–22056 Alarms, smtp, attempts Email attempts

22057–22058 Alarms, smtp, fails Email failures

22100 Number of read maps in default
Read Map statistics

22101 Number of read map successes

Continued on page 18
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Continued from page 17

Registers Definition

22102 Number of read map timeouts

22103 Number of read map errors

22104 Read map success streak

22105 Number of write map successes

Write Map statistics
22106 Number of write map timeouts

22107 Number of write map errors

22108 Write map success streak

22109 Number of passthrough successes

API message passing statistics
22110 Number of passthrough timeouts

22111 Number of passthrough errors

22112 Passthrough success streak

23000 Read map success count

Read/Write maps statistics

24000 Write map success count

25000 Read map timeout count

25000 Write map timeout count

27000 Read map error count

28000 Write map error count

29000 Read map success streak

30000 Write map success streak

31000 Read map is in default

TCP Client Stats—The "x" represents the socket 0 through 2. The flex socket is not used. This range repeats for the next 
socket.

TCP client statistics

Register Definition

2x001 Socket x connection attempts (20001 is the first socket, 21001 is the second socket...)

2x003 Socket x connections

2x005 Socket x disconnections

2x007 Socket x transmits

2x009 Socket x receives

2x011 Socket x resolver attempts (reserved)

2x013 Socket x resolvers (reserved)

2x015–2x020 Reserved

2x021 Socket x Rule 0 transmits

2x023 Socket x Rule 0 receives

2x025 Socket x Rule 0 timeouts

2x027 Socket x Rule 0 broadcasts

2x029 Reserved

2x031 Socket x Rule 1 transmits

2x033 Socket x Rule 1 receives

2x035 Socket x Rule 1 timeouts

2x037 Socket x Rule 1 broadcasts

Continued on page 19
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Continued from page 18

Register Definition

2x039 Reserved

Reset Codes—The reset codes are in virtual register 11015 and define the condition of the last restart operation.

Reset codes

Reset Code Definition

0 Undefined

1 Unknown

2 General

3 Brownout

4 Watchdog

5 User

6 Software

7 Return from backup mode

Connecting to Remote IO-Link Devices
Use the DXMR90-4K's IO-link ports for connecting IO-Link devices and digital sensors, lights, and actuators. All ports use an 
M12 female connector to connect to remote devices. No additional wiring is required if the sensors use compatible wiring.

Ports 1-4 female connector

Port 1–4 5-pin M12 female connector Pin  Wire Color   Description 

2

3
4

1

5
 

1  Brown (bn)  18 V DC to 30 V DC 

2  White (wh)  I/Q (digital in-out) 

3  Blue (bu)  DC common (GND) 

4  Black (bk)  C/Q (communications/digital in-out) 

5  Gray (gy)  No connection/not used

The basic communications parameters for the IO-Link ports are set in the DXM Configuration Software and are saved in the 
XML configuration file. Each port can have unique settings.



Controller Connections for the DXMR90-4KDXMR90-4K IO-Link Master Product Manual

27-Feb-25page 20 of 44 © Banner Engineering Corp. All rights reserved. 
www.bannerengineering.com

RTU Configuration screen for ports 1-4

To configure the IO-Link master port settings using the DXM Configuration Software, go to Register Mapping › IO-Link. The 
operating mode can be configured for any port on the IO-Link master. The following modes can be used:

Deactivated
Use deactivated mode for any unused IO-link master ports if a 
device is not connected. 

IO-Link Manual 
The IO-Link master only connects IO-Link devices that have a 
certain vendor ID and device ID (1: IOL_MANUAL). 
This mode is also required to for the Backup and Restore or 
Restore function. 

IO-Link Autostart 
The IO-Link master connects to every connected IO-Link 
device (2: IOL_AUTOSTART). 

Digital Input 
The IO-Link port functions as a standard digital input (3: DI_C/
Q). 

Digital Output 
The IO-Link port functions as a standard digital output (4: 
DO_C/Q). 

For more information on the port settings of the DXMR90-4K IO-Link Master, refer to the IO-Link Master Data Reference 
Guide.

Replacing an IO-Link Device During Operation (Backup/Restore Mode)
Replacing an IO-Link device during operation is common, and inadvertent changes to device settings can cause operational 
problems and down-times. Operating personnel without special knowledge or tools can replace IO-Link devices quickly and 
without errors.

When the backup function of the IO-Link master is used, the IO-Link master automatically provides the saved parameters to 
the new device after replacement. This makes IO-Link device replacement seamless in IO-Link applications. Another 
common industry term for this function is data storage mode.

. Backup+Restore Mode
If a port on the IO-Link master is set to Backup+Restore, then 
the new device added to the IO-Link port takes in the same 
device configuration as the device that was just replaced, as 
the IO-Link master had stored the last configuration change 
by a backup (3: Type compatible Device V1.1, Backup + 
Restore).

. Restore
If the port on the IO-Link master port is set to Restore, then 
the new device takes in the configuration according the 
settings saved in the master at the time of the last backup. 
Because possible configuration changes were not saved in 
the master, a different behavior from the previous one before 
the replacement may occur (4: Type compatible Device V1.1, 
Restore).
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Configuring Connected Banner IO-Link Devices
Banner's IO-Link Configuration Software offers an easy way to configure Banner IO-Link masters and Banner IO-Link 
devices, offering users control of master and device configuration.

The easy-to-use software provides various tools and works with the DXM110-8K, DXMR90-4K, R90C-4K-MQ, and R45C-2K-
MQ IO-Link Masters. Configure Banner IO-link Masters and IO-Link devices using the free IO-Link Configuration Software, 
available for download on the product page for the DXMR110-8K at: https://www.bannerengineering.com/us/en/products/
part.814332.html.

Like the DXM Configuration Software, this software enables you to configure port settings for the DXMR90-4K. It also can 
configure Banner IO-link Devices connected to the DXMR90-4K and to configure the IP address settings of the DXMR110-8k 
and DXMR90-4K IO-Link masters.

For instructions on how to use the software to configure IO-link port settings and IO-link devices connected to the IO-link 
master, use the IO-Link Configuration Software Instruction Manual, available from the software by going to Help › Help File. 
The IO-link Configuration Software Instruction manual can also be downloaded directly on the product page for the 
DXMR90-4K.

IO-Link configuration start page

http://www.bannerengineering.com/us/en/products/part.814332.html
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IO-Link configuration to select Ethernet

Connecting to Remote Modbus Devices
In addition to the four IO-link ports, the DXMR90-4K has one Modbus client port to connect to remote devices. No additional 
wiring is required if the sensors use compatible wiring.

Port 0 female connector

Port 0 5-pin M12 female connector Pin  Wire Color   Description 

2

3
4

1

5
 

1 Brown (bn)  18 V DC to 30 V DC 

2 White (wh)  RS485 / D1 / B / + 

3 Blue (bu)  DC common (GND) 

4 Black (bk)  RS485 / D0 / A / - 

5 No connection/not used

The DXMR90-4K can be a Modbus RTU client device to other server devices and can be a Modbus server device to another 
Modbus RTU client. The DXMR90-4K uses female port 0 as a Modbus RTU client port to control external server devices. All 
wired devices connected to the client RS-485 port must be server devices.

As a Modbus RTU client device, the DXMR90-4K controls external servers connected to female M12 port 0
As a Modbus RTU server device, the DXMR90-4K local registers can be read from or written to by another Modbus 
RTU client device via port 0.

The Modbus RTU server connection, port 0, is controlled by another Modbus client device that is not the DXMR90-4K. The 
server port is used by an external Modbus client device that will access the DXMR90-4K as a Modbus server device. Use the 
DXM Configuration Software to define the operational settings for both the Modbus RTU client port 0 and the Modbus RTU 
server port 0.

The basic communications parameters for the RS-485 ports are set in the DXM Configuration Software and are saved in the 
XML configuration file.

Create an RTU Read Rule for the DXMR90-4K
Follow these steps to create a new read rule.

This example creates a read rule to read six registers (address 1 through 6), from Port 0 Modbus server 4. The results are 
stored in the Local Registers 12001 through 12006.
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System settings

Example Read Rules Configuration

Example Read Rules configuration settings

Go to Settings › System to define the port settings to be compatible with the connected devices.

The Baud rate is defined for both the Modbus client and server; settings include 19200 (default), 1200, 2400, 9600, 
38400, 57600, and 115200. The Delay between messages applies to the Modbus client port and sets the minimum 
wait time from the end of a Modbus transaction to the beginning of the next Modbus transaction. Parity is defined for 
both the Modbus client and server; settings include None (default), odd, even, space, and mark. Timeout applies to 
the Modbus client port and covers the expected time for messages to be sent throughout the wireless network. For 
the DXM, the Timeout parameter is the maximum amount of time the DXM should wait after a request is sent until the 
response message is received from the Modbus server device.

1. 
Verify the Baud rate and Parity match that of the connected Modbus server devices.a. 
The timeout controls how long the DXMR90 waits before determining a command has failed to send. Set the 
timeout based on your specific application requirements.

b. 

The Delay between messages defines the minimum wait time between resending another command. Set the 
delay based on your specific application requirements.

c. 

From the Register Mapping › RTU › RTU Read screen, click Add Read Rule.2. 

Click the arrow next to the name to display the parameters.3. 

Name your rule.4. 

Select the server ID.5. 

Select how many registers to read, and the beginning register.6. 

Define the register type, how often to read the register, and any other appropriate parameters.7. 

If necessary, select the error condition. For this example, if the read function fails after three attempts, the read rule 
writes 12345 to the DXM local registers. Notice the list of local register names this read rule is using.

8. 
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Set the Controller to use Authentication
The DXMR90-4K can be configured to send login and password credentials for every HTTP packet sent to the webserver. 
This provides another layer of security for the webserver data.

Configuration requires both the webserver and the DXMR90-4K to be given the same credentials for the login and password. 
The webserver authentication username and password are not stored in the XML configuration file and must be stored in the 
DXMR90-4K.

Set the Web Services to Use Authentication

Configuration InstructionsChapter 5 

From within the DXM Configuration Software, go to the Settings › Cloud Services screen.1. 

In the upper right, select Show advanced settings.2. 

Web Server Authentication screen

Define the username and password in the Web Server Authentication section of the screen.
The first time you select Require Authentication, a pop-up box appears 
with additional instructions. Since the data is not stored in the XML 
configuration file, it is hidden from view of the DXM Configuration 
Software.

3. 

Click on Send Authentication.
The controller must be connected to the PC for this operation to 
succeed.
The data transmits directly to the DXMR90-4K's non-volatile memory. 
If successful, a pop-up window appears, asking to reboot the device.

4. 

Select Yes to reboot the device.5. 

At the Banner Cloud Data Services website, go to Settings › Sites.1. 

To edit the site settings, click Edit on the line of the site name.

Settings > Sites screen of the Banner CDS website

At the bottom of the pop-up window is a checkbox to enable authentication/validation.

2. 
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Settings > Administration screen

Controller Configuration Authentication
The DXMR90-4K can be programmed to allow changes to the configuration files only with proper authentication by setting up 
a password on the Settings › Administration screen in the DXM Configuration Software.

With the DXMR90-4K connected to the PC, click Get 
Device Status. The DXMR90-4K status displays next to 
the button.

Use the DXM Configuration Software to:
Set the Admin Password
Change the Admin Password
Remove the Admin Password

To change or remove an admin password, you are 
required to enter the current password and the 
DXMR90-4K must be connected to the PC.

Register Flow and 
Configuration
The DXMR90-4K register data flow goes through the Local Registers, which are data storage elements that reside within the 
processor. Using the configuration software, the controller can be programmed to move register data from the Local Register 
pool to remote devices or the I/O base.

Register flow

Processor

Ethernet

Local
Registers I/O Base

Remote Devices

Basic Approach to Configuration
When programming an application in the DXMR90-4K, first plan the overall data structure of the Local Registers. The Local 
Registers are the main storage elements in the DXMR90-4K. Everything goes into or out of the Local Registers.

Troubleshooting a Configuration
View Local Registers using the Local Registers  › Local Registers in Use screen of the configuration software.

When a configuration is running on the DXMR90-4K, viewing the Local Registers can help you to understand the 
application's operation. This utility can also access data from remote devices and LED registers.

Enter the same username and password as used in the DXM Configuration Software. The username and password 
do not need to be a defined user within the Banner Cloud Data Services website.

3. 

In the DXM Configuration Software, name the Local Registers to provide the beginning structure of the application.1. 
Configure the read/write rules to move the data. The Read/Write rules are simple rules that move data between 
devices (Nodes, Modbus servers, sensors, etc) and the Local Registers.

2. 

Most applications require the ability to manipulate the Local Register data, not just move data around. Use the Action 
rules to make decisions or transform the data after the data is in the Local Registers. Action rules can apply many 
different functions to the Local Register data, including conditional statements, math operations, copy operations, or 
trending.

3. 

To perform scheduled events in Local Registers, go to the Scheduler screen in the DXM Configuration Software. 
These rules provide the ability to create register events by day of the week. The scheduler can also create events 
based on sunrise or sunset.

4. 
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Saving and Loading Configuration Files
The DXM Configuration Software saves its configuration information in an XML file. Use the File menu to Save or Load 
configuration files.

Save the configuration file before attempting to upload the configuration to the DXMR90-4K. The DXM Configuration 
Software uploads the configuration file saved on the PC to the DXMR90-4K; it will not send the configuration loaded in the 
tool.

Uploading or Downloading Configuration Files
The DXMR90-4K requires a XML configuration file to become operational. To upload or download configuration files, connect 
a computer to the DXMR90-4K using the Ethernet port. Then use the Upload Configuration to Device or Download 
Configuration from Device under the Device menu.

EtherNet/IP™ Configuration
The DXMR90-4K can be configured to send/receive local register data to and from an EtherNet/IP™(2) host. EDS (Electronic 
Data Sheet) files allow users of the EtherNet/IP protocol to easily add a Banner DXM device to the PLC. Download the EDS 
files from the Banner website.

DXM EDS Configuration File (for PLCs) (p/n b_4205242)
DXM EIP Config File for DXM Controller with Internal Gateway (Models: DXM1xx-BxR1, DXM1xx-BxR3, and 
DXM1xx-BxCxR1) (p/n 194730)

Configuring the Host PLC
On the host PLC, install the DXMR90-4K using an EDS file or by using the following parameters:

Assembly1: Originator to DXM = Instance 112, 456 bytes (228 words)
Assembly2: DXM to Originator = Instance 100, 456 bytes (228 words)

The Originator is the host PLC system, and the DXM is the DXMR90-4K. The host system sees the DXMR90-4K as a generic 
device with the product name of Banner DXM (ProdType: 43 - Generic Device, ProdName: Banner DXM, Integer Type - INT).

IMPORTANT: Do not set the Requested Packet Interval (RPI) any faster than 20 ms.

Configuring the Controller
Use the configuration software to define the Protocol conversion for each local register to be EIP Originator › DXM or EIP 
DXM › Originator from the Edit Register or Modify Multiple Register screens.

Define a DXM local register as EIP Originator › DXM when the host PLC (Originator) will send data to the DXMR90-4K local 
register (DXM).

Define a DXM local register as EIP DXM › Originator when that register data will be sent from the DXMR90-4K (DXM) to the 
host PLC (Originator).

Data from an EIP controller in assembly instance 112 is data destined for the DXMR90-4K local registers. The PLC is 
normally configured for INT or UINT data transfer. This allows for a seamless transfer of data.

EIP Assembly Instance 112 (16-bit) DXM Local Registers

Adrs Data Adrs Data

0 1122 1 1122

1 3344 2 3344

2 5566 3 5566

3 7788 4 7788

4 9900 5 9900

Data from the DXMR90-4K local registers is sent to the EIP controller using assembly instance 100. Each local register in the 
DXMR90-4K defined as EIP DXM › Originator is collected in numerical order and placed into the data buffer destined for 

http://info.bannerengineering.com/cs/groups/public/documents/product_data_files/b_4205242.zip
http://info.bannerengineering.com/cs/groups/public/documents/product_data_files/194730.zip
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assembly instance 100. DXM local registers are capable of 32-bits, but only the lower 2-bytes (16-bits) for each local register 
are transferred.

EIP Assembly Instance 100 (16-bit) DXM Local Registers

Adrs Data Adrs Data

0 1122 11 1122

1 3344 12 3344

2 5566 13 5566

3 7788 14 7788

4 9900 15 9900

Commissioning and Connecting IO-Link Devices to a Rockwell 
PLC with Add-On Instructions
An Add-On-Instruction or AOI is a feature introduced by Rockwell Software in version 16 of RSLogix 5000 programming 
software. An AOI enables users to develop and package PLC code in user-defined instructions that are reused throughout 
their program.

Banner has developed three types of IO-Link related Add On Instruction (AOI) files for use with the Logix Designer software 
package from Rockwell Automation.

Process Data AOIs (v2)—These files can be used alone, without needing any other IO-Link AOIs. The job of a Process Data 
AOI is to intelligently parse out the Process Data word(s) into separate pieces of information. All that is required to use this 
AOI is an EtherNet/IP connection to the IO-Link Master and knowledge of where the Process Data registers are located for 
each port.

Parameter Data AOIs (v2.1)—These files require using an associated IO-Link Master AOI. The job of a Parameter Data AOI, 
when working in conjunction with the IO-Link Master AOI, is to provide quasi-realtime read/write access to all IO-Link 
parameter data in the sensor. Each Parameter Data AOI is specific to a given sensor.

IO-Link Master AOIs (v2.1)—These files require using one or more associated Parameter Data AOIs. The job of an IO-Link 
Master AOI is to translate the desired IO-Link read/write requests, made by the Parameter Data AOI, into the format a 
specific IO-Link Master requires. Each IO-Link Master AOI is custom-made for a given brand of IO-Link Master. Add and 
configure the relevant Banner IO-Link Master AOI in your ladder logic program first; then add and configure Banner IO-Link 
Device AOIs as desired, linking them to the Master AOI as shown in the relevant AOI documentation.

Instructions for using the DXMR90-4K AOI can be found on the DXMR90-4K product page on the Banner website.

Add-on instructions for different Banner IO-link devices can be downloaded on the Banner website. Included in the download 
are PDF instructions for how to use the files.

Example AOIs listed on the Banner Engineering product page for the Q4X Series Sensor

In the Logix Designer software, you can import the Add-On Instructions.
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Import Add-On Instructions

Push Retries
Ethernet—The DXMR90-4K can be configured to send register data packets to a web server. When the Ethernet 
communications path is not operating, the DXMR90-4K retries the send procedure. With an Ethernet-based network 
connection, the DXMR90-4K retries a message five times. The five retry attempts immediately follow each other. After all 
attempts are exhausted, the register data packet is lost. At the next scheduled time, the DXMR90-4K attempts to send only 
the new data. Any past data that the DXMR90 was unable to push is lost and cannot be recovered. Using SSL on Ethernet 
will have no retries.

Event/Action—Event-based pushes caused by Action rules sent using email follow the same process when failures occur, 
based on the network connection.

Email—There are no retries for emails that fail to be sent from the DXMR90-4K.
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PROFINET is a data communications protocol for industrial automation and processes. PROFINET IO defines how 
controllers (IO controllers) and peripheral devices (IO devices) exchange data in real-time. PROFINET® is a registered 
trademark of PROFIBUS Nutzerorganisation e.V. and the standard is maintained by PROFIBUS & PROFINET International 
(PI), an organization headquartered in Karlsruhe, Germany.

Only the DXMR90-4K, DXMR90-X1, DXMR110-8K, DXM700, DXM1000, and DXM1200 Controller models support 
PROFINET IO.

General Station Description Markup Language File
A PROFINET General Station Description (GSD) file is a description of an IO device provided by the device manufacturer in 
an XML format (GSDML.xml).

The GSD file is a standardized way of describing the device information to engineering tools and the IO controller and can 
work across a variety of tools as a standard set of device information.

DXM PROFINET IO Data Model
The PROFINET IO data model is based on the typical, expandable field device that has a backplane with slots. Modules 
have different functionalities.

Modules are plugged into slots. In the PROFINET IO data model, Slot 0, Subslot 1 is reserved for the Device Access Point 
(DAP) or network interface.

Configure the DXM Controller for a PROFINET IO Connection
To use PROFINET, follow these instructions.

The PROFINET data type and data size to/from the DXM Controller is configurable. The PROFINET data is processed from 
the Local Register of the DXM Controller.

Configure the IO-Link ports in the XML according to the modules selected for each port.

Save and Upload the Configuration File
After making any changes to the configuration, you must save the configuration files to your computer, then upload it to the 
device.

Changes to the XML file are not automatically saved. Save your configuration file before exiting the software and before 
sending the XML file to the device to avoid losing data. If you select DXM › Send XML Configuration to DXM before saving 
the configuration file, the software will prompt you to choose between saving the file or continuing without saving the file.

PROFINET®Chapter 6 

Using the DXM Configuration Software, go to the Settings › Ethernet screen.1. 

Select Enable PROFINET.2. 

Save the configuration file and upload it to the DXM Controller (see "Save and Upload the Configuration File" on page 
13).
After PROFINET is enabled, the IP address for the DXM Controller is controlled by the PROFINET host.

3. 

Save the XML configuration file to your hard drive by going to the File › Save As menu.1. 

Go to the DXM › Send XML Configuration to DXM menu.2. 
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Slots and Modules for DXMR90-4K and DXMR110-8K 
PROFINET
There are ten slots to accommodate the DXM Controller data.

Slots for input and output values

Values Maximum Data Size

Input values 1440 bytes

Output values 1440 bytes

Slot 1 - Input (DXM --> PLC)

Module ID Submodule ID Module Size (bytes) Register Start Register End Direction

0x44 0x01 Banner IO-Link 
Client Info 9

1 3

Input6 6

123 123

It is important to note that the module placed in slot 2 corresponds to Port 1; the module placed in slot 3 corresponds to Port 
2; the module placed in slot 4 corresponds to port 3. etc.

For the DXMR90-4K IO-Link Client device, slots 6 through 9 are unused.

If the IO-Link In/Out process data modules (all except digital input and output) are used, the attached IO-Link device must 
have PDI and PDO size less than or equal to the number of data bytes allowed in the module. Data transfers will not be 
applied otherwise. For example, plugging in the 16/16 byte module to a slot corresponding to a device that has 22 bytes of 
PDO results in an error. Process data sent from the PLC to DXM will not be applied.

Slots 2-9 (1 per IO-link port)

Module ID Submodule ID Module Size (bytes) Register Start Register End Direction

0x45 0x01 IO-Link In/Out 32/32 Byte + Status

36
x001 x017

Bidirectional
x506 x507

46
x051 x067

x851 x859

0x46 0x01 IO-Link In/Out 16/16 Byte + Status

20
x001 x009

Bidirectional
x506 x507

30
x051 x059

x851 x859

0x47 0x01 IO-Link In/Out 8/8 Byte + Status
12

x001 x005

Bidirectionalx506 x507

22 x051 x055

Continued on page 31

◦

◦
◦

Status indicator bar

If the Application Status indicator is red, close and restart the DXM Configuration Software, unplug and re-plug 
in the cable and reconnect the DXM to the software.
If the Application Status indicator is green, the file upload is complete.
If the Application Status indicator is gray and the green status bar is in motion, the file transfer is in progress.

After the file transfer is complete, the device reboots and begins running the new configuration.
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Continued from page 30

Module ID Submodule ID Module Size (bytes) Register Start Register End Direction

x851 x859

0x48 0x01 IO-Link In/Out 4/4 Byte + Status

8
x001 x003

Bidirectional
x506 x507

18
x051 x053

x851 x859

0x49 0x01 IO-Link In/Out 2/2 Byte + Status

6
x001 x002

Bidirectional
x506 x507

16
x051 x052

x851 x859

0x4A 0x01 IO-Link In/Out 1/1 Byte + Status

5
x001 x002

Bidirectional
x506 x507

15
x051 x052

x851 x859

0x4B 0x01 Digital Output 5

x051 x051

Output Module
x851 x851

x853 x853

x858 x858

0x4C 0x01 Digital Input

2 x001 x001

Bidirectional
4

x051 x051

x851 x851

x853 x853

x858 x859

Slot 10 (ISDU)

Module ID Submodule ID Module Size (bytes) Register Start Register End Direction

0x4D 0x01 ISDU 190 Byte + Status
196 351 442

Bidirectional
196 200 291

0x4E 0x01 ISDU  80 Byte + Status
86 351 396

86 200 245

Example Configuration

Slot Module Description

Slot 1 Banner IO-Link Client Info Vendor ID, Device ID, Number of Supported Channels, and Firmware 
Version information

Slot 2 IO-Link In/Out 32/32 Byte + Status Get/send IO-Link PDI/PDO for IO-Link device on Port 1 with PD Size 
between 17 and 32 bytes

Slot 3 IO-Link In/Out 16/16 Byte + Status Get/send IO-Link PDI/PDO for IO-Link device on Port 2 with PD Size 
between 9 and 16 bytes

Slot 4 IO-Link In/Out 2/2 Byte + Status Get/send IO-Link PDI/PDO for IO-Link device on Port 3 with PD Size 
between 1 and 2 bytes

Slot 5 Digital Output Use SIO Output mode on Port 4

Slot 10 ISDU 190 Byte + Status ISDU read/write access for all ports in IO-Link mode
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Slots and Modules for the DXMR90-X1, DXM700, 
DXM1000, and DXM1200 PROFINET
There are nine slots to accommodate the DXM Controller data.

Slots for input and output values

Values Slots Maximum Data Size

Input values 1–6 1440 bytes

Output values 7–9 1440 bytes

Listing of slots for input and output values

Slot
PLC DXM Local Register Module Size

Module Definition Start End 512

Slot 1 Inputs Integer <- 1 256

Slot 2 Inputs Integer <- 257 512

Slot 3 Inputs Integer <- 513 768

Slot 4 Inputs Float <- 1001 1256

Slot 5 Inputs Float <- 1257 1512

Slot 6 Inputs Float <- 1513 1768

Slot 7 Output Integer -> 5001 5256

Slot 8 Output Integer -> 5257 5512

Slot 9 Output Integer -> 5513 5768

The DXM Local Register association shown uses a Module size of 512 bytes, which equals 256 Local Registers in the DXM. 
Module sizes supported are 64, 128, 256 and 512 bytes. Input Integers are data from the DXM to the PLC. Output integers 
are data from the PLC to the DXM.

Slots 1 through 3

Module Notes

Input Integer 512 Allowed in slots 1-3, Module Identifier= 0x30

Input Integer 256 Allowed in slots 1-3, Module Identifier= 0x31

Input Integer 128 Allowed in slots 1-3, Module Identifier= 0x32

Input Integer 64 Allowed in slots 1-3, Module Identifier= 0x33

Slots 4 through 6

Module Notes

Input Float 512 Allowed in slots 4-6, Module Identifier= 0x34

Input Float 256 Allowed in slots 4-6, Module Identifier= 0x35

Input Float 128 Allowed in slots 4-6, Module Identifier= 0x36

Input Float 64 Allowed in slots 4-6, Module Identifier= 0x37

Slots 7 through 9

Module Notes

Output Integer 512 Allowed in slots 7-9, Module Identifier= 0x40

Continued on page 33
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Continued from page 32

Module Notes

Output Integer 256 Allowed in slots 7-9, Module Identifier= 0x41

Output Integer 128 Allowed in slots 7-9, Module Identifier= 0x42

Output Integer 64 Allowed in slots 7-9, Module Identifier= 0x43

Example configuration for slots and modules

Slot Module Description

Slot 1 Input Integer 512 The two input integer modules have a total of 640 bytes (320 Modbus registers)
The data will come from DXM Local Registers 1 through 320Slot 2 Input Integer 128

Slot 4 Input Float 128
The input Floating register module has a total of 128 byes (64 Modbus registers)
Since it takes two Modbus registers to make a 32-bit floating value, there will be 32 floating point values 
coming from Local Registers 1001-1064

Slot 7 Output Integer 64 The output integer 64 module has a total of 64 bytes (32 Modbus registers).
The data will come from the PLC and be put into DXM Local Registers 5001 through 5032

Configuration Instructions
Install the GSD File
Although these instructions are specific for the Siemens TIA Portal (v14) software, you may use these instructions as a basis 
for installing the GSD file into another controller.

Download the GSD file from www.bannerengineering.com.1. 

Launch the Siemens TIA Portal (v14) software.2. 

Click Open existing project.3. 

Select a project and open it.4. 

After the project is uploaded, click Devices & networks.

Devices and networks screen

5. 

Click Configure networks.6. 

http://www.bannerengineering.com
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If the DXM GSD file does not install properly, save the log and contact Banner Engineering Corp.

Configure networks screen

Click Options and select Manage general station description file (GSD).
The Install general station decription file window opens.

7. 

Click the More options (...) icon to the right of the Source path field and browse to the location the DXM GSD file was 
downloaded to.

8. 

Select the DXM GSD file.9. 

Click Install.

Hardware catalog

The system installs the DXM GSD file and places it in the Hardware catalog. In the example, the DXM GSD file is 
located under Other field devices › PROFINET IO › Banner Engineering Corp. › Banner.

10. 
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Change the Device IP Address
Follow these instructions to change the IP address of the DXM device using the Siemens TIA Portal (v14) software. Use 
these instructions as a basis if you are using another controller (PLC).

Launch the Siemens TIA Portal (v14) software.1. 

Click Open existing project.2. 

Select a project and open it.3. 

Click Devices & networks.

Network view

The Network view displays.

4. 

Double-click on the DXM icon to open the Device view screen.5. 

Click on the DXM icon in the graphic area of the Device view screen.
The Module properties window displays and the module can now be configured.

6. 

Click Properties.7. 

Click General.8. 

Select PROFINET Interface › Ethernet addresses.

Ethernet addresses

9. 

Select Set IP address in the project.10. 

Enter the IP address.11. 

Right-click on the device icon and select Online & diagnostics.12. 
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By default, each DXM shipped from the factory is assigned the IP address 192.168.0.1.

Immediately after the PROFINET protocol is enabled, the DXM has an IP address of 0.0.0.0. We recommend using the TIA 
Portal to give the DXM an IP address so that the address is saved in the unit. When the PLC powers up, this IP address is 
accessible. The PLC can change the IP address if it is configured to do so.

If the PLC assigns the DXM IP address (for example, using the Set IP address in the project option in Siemens TIA Portal), 
the DXM receives the specified address, but only after the program has been loaded into the PLC and is running. If the DXM 
is restarted after it was discovered and configured by the PLC, the DXM retains the IP address that was assigned to it using 
the LCD or software until after the PLC discovers the DXM and assigns it the specified address again. However, if this 
address is different than what is specified in the PLC, the DXM reverts to the address specified in the PLC after the PLC 
becomes active again.

These configuration options conform to the PROFINET standard.

Change the Device Name
Follow these instructions to change the name of the DXM using the Siemens TIA Portal (v14) software. Use these 
instructions as a basis if you are using another controller (PLC).

Online & diagnostics menu and screen

The Online & diagnostics windows displays.

Select Assign IP address under Functions.13. 

Click Accessible devices.
The Select device window searches the network for available devices.

14. 

Determine the device to be adjusted via the MAC address and select it.15. 

Click Apply.
The IP address for the device is updated.

16. 

Click Assign IP address to complete the step.
This step is completed for every device.

17. 

Open a project and click on Devices & networks.1. 
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The Network view displays.

Right-click on the DXM icon and select Assign device name.
The Assign PROFINET device name window displays. The software searches for devices of the same type.

2. 

Enter the desired name in the PROFINET device name field. Note that each name can be used only once.3. 

Click Assign name.
The device now has a PROFINET name.

4. 
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Power Supplies
PSD-24-4—DC Power Supply, Desktop style, 3.9 A, 24 V DC, Class 2, 4-pin M12 quick disconnect (QD)
PSDINP-24-06—DC power supply, 0.63 Amps, 24 V DC, with DIN Rail Mount, Class I Division 2 (Groups A, B, C, D) 
Rated 
PSDINP-24-13 —DC power supply, 1.3 Amps, 24 V DC, with DIN Rail Mount, Class I Division 2 (Groups A, B, C, D) Rated
PSDINP-24-25 — DC power supply, 2.5 Amps, 24 V DC, with DIN Rail Mount, Class I Division 2 (Groups A, B, C, D) 
Rated
PSW-24-1—DC power supply with multi-blade wall plug, 100–240 V AC 50/60 Hz input, 24 V DC 1 A output, UL Listed 
Class 2, 4-pin female M12 connector
PSWB-24-1—DC power supply with multi-blade wall plug,100–240 V AC 50/60 Hz input, 24 V DC 1 A output, UL Listed 
Class 2, barrel jack connector

SMBR90S 

Stainless steel bracket 
4x M4-07 pemnuts (B) 
Includes 2x M4 stainless steel hex head screws and flat washers 

Hole center spacing: A = 40, B = 20
Hole size: A = ø 5

 

A

B

74

10.1
24

8.6

 

Double-Ended 4-pin M12 Male D-code to 8-Pin RJ45 Male Shielded Ethernet Cordsets

Model  Length  Dimensions  RJ45 Pinout (Male)  M12 Pinout (Male)

STP-M12D-403  0.9 m (2.95 ft) 

47.4 Typ.

ø 14.5
M12 x 1.0

RJ45

Ø 6.2 mm

 

1 = White/Orange 
2 = Orange 
3 = White/Blue 
6 = Blue 

3

1

2

4

1 = White/Orange 
2 = White/Blue 
3 = Orange 
4 = Blue

STP-M12D-406  1.83 m (6 ft) 

STP-M12D-415   4.57 m (15 ft) 

STP-M12D-430   9.14 m (30 ft) 

4-pin A-Code Double-Ended M12 Female to M12 Male Cordsets

Model Length Dimensions (mm) Pinouts  

BC-M12F4-M12M4-22-1 1 m (3.28 ft)
40 Typ.
[1.58"]

ø 14.5 [0.57"]
M12 x 1

44 Typ.
[1.73"]

ø 14.5 [0.57"]
M12 x 1

Female
2

34

1

Male

1

4
3

2

1 = Brown 
2 = White 
3 = Blue 
4 = Black 

BC-M12F4-M12M4-22-2 2 m (6.56 ft)

BC-M12F4-M12M4-22-3 3 m (9.84 ft)

BC-M12F4-M12M4-22-4 4 m (13.12 ft)

BC-M12F4-M12M4-22-5 5 m (16.4 ft)

BC-M12F4-M12M4-22-10 10 m (30.81 ft)

BC-M12F4-M12M4-22-15 15 m (49.2 ft)

DXMR90-4K AccessoriesChapter 7 

http://info.bannerengineering.com/cs/groups/public/documents/literature/173620.pdf
http://info.bannerengineering.com/cs/groups/public/documents/literature/180340.pdf
http://info.bannerengineering.com/cs/groups/public/documents/literature/180340.pdf
http://info.bannerengineering.com/cs/groups/public/documents/literature/180340.pdf
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4-pin A-Code Double-Ended M12 Female to M12 Male Right-Angle Cordsets

Model Length Dimensions (mm) Pinouts  

BC-M12F4-M12M4A-22-1 1 m (3.28 ft)

44 Typ.
[1.73"]

ø 14.5 [0.57"]

M12 x 1

32 Typ.
[1.26"]

30 Typ.
[1.18"]

ø 14.5 [0.57"]
M12 x 1

Female
2

34

1

Male

1

4
3

2

1 = Brown 
2 = White 
3 = Blue 
4 = Black 

BC-M12F4-M12M4A-22-2 2 m (6.56 ft)

BC-M12F4-M12M4A-22-5 5 m (16.4 ft)

BC-M12F4-M12M4A-22-8 8 m (26.25 ft)

BC-M12F4-M12M4A-22-10 10 m (30.81 ft)

BC-M12F4-M12M4A-22-15 15 m (49.2 ft)

4-pin A-Code Double-Ended M12 Female Right-Angle to M12 Male Right-Angle Cordsets

Model Length Dimensions (mm) Pinouts  

BC-M12F4A-M12M4A-22-0.3 0.3 m (1 ft)
32 Typ.
[1.26"]

30 Typ.
[1.18"]

ø 14.5 [0.57"]
M12 x 1

31 Typ.

32 Typ.

Female
2

34

1

Male

1

4
3

2

1 = Brown 
2 = White 
3 = Blue 
4 = Black 

BC-M12F4A-M12M4A-22-1 1 m (3.28 ft)

BC-M12F4A-M12M4A-22-2 2 m (6.56 ft)

BC-M12F4A-M12M4A-22-5 5 m (16.4 ft)

BC-M12F4A-M12M4A-22-8 8 m (26.25 ft)

BC-M12F4A-M12M4A-22-10 10 m (30.81 ft)

BC-M12F4A-M12M4A-22-15 15 m (49.2 ft)
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Specifications
Supply Voltage

18 V DC to 30 V DC
Supply Protection Circuitry

Protected against reverse polarity and transient voltages
Power Consumption

24 V DC at 100 mA + 200 mA/port = 900 mA maximum
Construction

Connector Body: PVC translucent black
Indicators

Amber/green: Program status indicators
Amber/green: Ethernet communications
Red/amber/green/blue on port 1: IO-Link Port 1 Status
Red/amber/green/blue on port 2: IO-Link Port 2 Status
Red/amber/green/blue on port 3: IO-Link Port 3 Status
Red/amber/green/blue on port 4: IO-Link Port 4 Status

Connections
Five 5-pin fixed nylon M12 female quick disconnect connector
One 5-pin nickel-plated brass M12 male quick disconnect 
connector
One 5-pin D-code fixed nylon M12 female quick disconnect 
connector

Application Note
When connecting external devices through the DXMR90-4K, it 
is important not to exceed the maximum current limitations of 
3.5 Amps

Communication Hardware (RS-485)
Interface: 2-wire half-duplex RS-485
Baud rates: 1.2K, 2.4K, 9.6k, 19.2k (default), 38.4k, 57.6K, or 
115.2K
Data format: 8 data bits, no parity, 1 stop bit

Communication Protocols
Modbus® RTU, PROFINET®, Modbus/TCP, EtherNet/IP™
EtherNet/IP™ is a trademark of ODVA, Inc. Modbus® is a 
registered trademark of Schneider Electric USA, Inc. 
PROFINET® is a registered trademark of PROFIBUS 
Nutzerorganisation e.V.

Security Protocols
TLS, SSL, HTTPS

Digital Inputs (SIO [DI] Mode)
Input Current: 5 mA typical
ON Voltage/Current: 15 V DC minimum/5 mA minimum
OFF Voltage: 5 V DC maximum

Digital Outputs (SIO [DO] Mode)
On-Resistance: 120 mΩ typical, 250 mΩ maximum
Current Limit: 0.7 A minimum, 1.0 A typical, 1.3 A maximum
Off Leakage Current: -10 μA minimum, 10 μA maximum

IO-Link Baud Rates
COM1: 4.8 kbps
COM2: 38.4 kbps
COM3: 230.4 kbps

Operating Conditions
–40 °C to +70 °C (–40 °F to +158 °F)
90% at +70 °C maximum relative humidity (non-condensing)

Storage Temperature
–40 °C to +80 °C (–40 °F to +176 °F)

Environmental Ratings
For Indoor Use Only
IP65, IP67, NEMA 1, UL Type 1

Vibration and Mechanical Shock 
Meets IEC 60068-2-6 requirements (Vibration: 10 Hz to 55 
Hz, 1.0 mm amplitude, 5 minutes sweep, 30 minutes dwell)
Meets IEC 60068-2-27 requirements (Shock: 30G 11 ms 
duration, half sine wave)

Certifications

Banner Engineering BV
Park Lane, Culliganlaan 2F bus 3
1831 Diegem, BELGIUM

Turck Banner LTD Blenheim House
Blenheim Court
Wickford, Essex SS11 8YT
GREAT BRITAIN

Required Overcurrent Protection

WARNING: Electrical connections must 
be made by qualified personnel in 
accordance with local and national 
electrical codes and regulations. 

Overcurrent protection is required to be provided by end 
product application per the supplied table. 
Overcurrent protection may be provided with external fusing 
or via Current Limiting, Class 2 Power Supply.

Product Support and MaintenanceChapter 8 
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Supply wiring leads < 24 AWG shall not be spliced.
For additional product support, go 
to www.bannerengineering.com. 

Supply 
Wiring 
(AWG)

Required Overcurrent 
Protection (A)

Supply 
Wiring 
(AWG)

Required Overcurrent 
Protection (A)

20 5.0 26 1.0

22 3.0 28 0.8

24 1.0 30 0.5

File System and Archive Process
The DXM file system is in a serial EEPROM that stores non-volatile configuration information. The serial EEPROM stores 
basic data that is required to be non-volatile, including network configuration data, IP address, MAC address, network masks, 
firewall settings, and authentication information.

The controller XML configuration file created by the DXM Configuration Software is stored in EEPROM. The small section of 
non-volatile local registers is also stored in EEPROM.

Update Your DXMR90 and DXMR110 Processor Firmware 
Using the Configuration Software
Follow these steps to update your DXMR90 and DXMR110 processor firmware using the DXM Configuration Software.

To verify the firmware has been updated, go to Tools › Reprogram › Get Device Information and verify the new versions are 
listed.

DXM Support Policy
The DXM Wireless Controllers are industrial wireless controllers that facilitate Industrial Internet of Things (IIoT) applications. 
As a communications gateway, it interfaces local serial ports, local I/O ports, and local ISM radio devices to the Internet using 
either a cellular connection or a wired Ethernet network connection. In a continuing effort to provide the best operation for 
the DXM, stay connected with Banner Engineering Corp to hear about the latest updates through the Banner website. Create 
a login today to stay informed of all Banner product releases.

Using the DXM Configuration Software version 4 or later, connect to the DXMR90-4K via Ethernet.
File loads to the DXMR90-4K will take several minutes.

1. 

On the DXM Configuration Software, go to Tools › Reprogram › Get Device Information to verify the current firmware 
version.
You must load a different version with the same firmware number for the bootloader to operate. Download firmware 
files from the Banner website.

Example Device Information screen; every device's information will be different

2. 

Under Tools › Reprogram, click Upload bootloader file to select the firmware file to program.3. 

Select the .HEX file provided to bootload the device.
This is a large file, so it may take 10-15 minutes to upload.

4. 

After the file load is completed, reboot the device by selecting DXM › Reboot DXM.
Upon reboot, the device will begin to bootload. There will be a solid green light on for 6 to 7 minutes. Do not be 
alarmed if the device appears to not do anything. After 6 to 7 minutes, an amber LED nearest the power connector 
flashes for 2 to 3 minutes. After the boatload process is finished, the device returns to normal operation.

5. 

DO NOT disconnect the power during the 6 to 7 minutes after the device cycles the power.6. 
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Firmware Updates
The DXM has been designed to be a robust and secure IOT device. To provide the most reliable and secure device possible, 
periodic firmware updates are released to enhance and expand the capabilities of the DXM. Firmware updates and 
description details are found on the Banner website. Customers with critical update requirements will get access to pre-
released firmware from the factory.

Website Information
The Banner website is the main method of disseminating DXM information to customers. The data found on the website 
include:

DXM instruction manuals
Configuration manuals
Firmware downloads
Firmware release notes
Errata data, any known issues with a release of firmware
Possible work-around solutions for known issues
DXM Solutions Guides

Feature Requests
Our customer is our most valuable resource to improve our DXM. If you have suggestions for improvements to the DXM or 
configuration software, please contact Banner Engineering Corp.

Potential DXM Issues
Potential issues with the DXM are collected from Banner's support engineers to provide solutions. Users can get help from 
the website documentation or by calling Banner Engineering for support help. Solutions are as simple as configuration 
adjustments, work-around configuration solutions, or potential new firmware updates.

DXM Security
The DXM was designed to collect local wireless sensor data, local sensor data, provide simple control, and send the data to 
the cloud.

The DXM does not run a Linux or Windows-based operating system but an embedded real-time operating system (RTOS) 
environment. As a proprietary operating system, the security aspects are easier to manage and minimize.

Security updates are released through the Banner Engineering Corp website (www.bannerengineering.com) and New 
Product Release Announcements (NPRA).

Contact Us
Banner Engineering Corp. headquarters is located at: 9714 Tenth Avenue North | Plymouth, MN 55441, USA | Phone: + 1 
888 373 6767

For worldwide locations and local representatives, visit www.bannerengineering.com.

Warnings
WARNING:

Do not use this device for personnel protection 
Using this device for personnel protection could result in serious injury or death.
This device does not include the self-checking redundant circuitry necessary to allow its use in personnel safety applications. A 
device failure or malfunction can cause either an energized (on) or de-energized (off) output condition.

IMPORTANT: Please download the complete DXMR90-4K IO-Link Master technical documentation, available in multiple languages, 
from www.bannerengineering.com for details on the proper use, applications, Warnings, and installation instructions of this device. 

IMPORTANT: Por favor descargue desde www.bannerengineering.com toda la documentación técnica de los DXMR90-4K IO-Link 
Master, disponibles en múltiples idiomas, para detalles del uso adecuado, aplicaciones, advertencias, y las instrucciones de instalación 
de estos dispositivos. 

http://www.bannerengineering.com
http://www.bannerengineering.com/us/en/company/press-releases.html#all
http://www.bannerengineering.com
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IMPORTANT: Veuillez télécharger la documentation technique complète des DXMR90-4K IO-Link Master sur notre site 
www.bannerengineering.com pour les détails sur leur utilisation correcte, les applications, les notes de sécurité et les instructions de 
montage. 

Install and properly ground a qualified surge suppressor when installing a remote antenna system. Remote antenna configurations installed without surge 
suppressors invalidate the manufacturer's warranty. Keep the ground wire as short as possible and make all ground connections to a single-point ground system 
to ensure no ground loops are created. No surge suppressor can absorb all lightning strikes; do not touch the Sure Cross® device or any equipment connected 
to the Sure Cross® device during a thunderstorm. 

Exporting Sure Cross® Radios. It is our intent to fully comply with all national and regional regulations regarding radio frequency emissions. Customers who want 
to re-export this product to a country other than that to which it was sold must ensure the device is approved in the destination country. The Sure Cross wireless 
products were certified for use in these countries using the antenna that ships with the product. When using other antennas, verify you are not exceeding the 
transmit power levels allowed by local governing agencies. This device has been designed to operate with the antennas listed on Banner Engineering’s website 
and having a maximum gain of 9 dBm. Antennas not included in this list or having a gain greater than 9 dBm are strictly prohibited for use with this device. The 
required antenna impedance is 50 ohms. To reduce potential radio interference to other users, the antenna type and its gain should be so chosen such that the 
equivalent isotropically radiated power (EIRP) is not more than that permitted for successful communication. Consult with Banner Engineering Corp. if the 
destination country is not on this list.

IMPORTANT:
Never operate a radio without connecting an antenna
Operating radios without an antenna connected will damage the radio circuitry.
To avoid damaging the radio circuitry, never apply power to a Sure Cross® Performance or Sure Cross® MultiHop radio 
without an antenna connected.

IMPORTANT:
Electrostatic discharge (ESD) sensitive device
ESD can damage the device. Damage from inappropriate handling is not covered by warranty.
Use proper handling procedures to prevent ESD damage. Proper handling procedures include leaving devices in their anti-
static packaging until ready for use; wearing anti-static wrist straps; and assembling units on a grounded, static-dissipative 
surface.

Banner Engineering Corp Limited Warranty
Banner Engineering Corp. warrants its products to be free from defects in material and workmanship for one year following the date of shipment. Banner 
Engineering Corp. will repair or replace, free of charge, any product of its manufacture which, at the time it is returned to the factory, is found to have been 
defective during the warranty period. This warranty does not cover damage or liability for misuse, abuse, or the improper application or installation of the Banner 
product.

THIS LIMITED WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL OTHER WARRANTIES WHETHER EXPRESS OR IMPLIED (INCLUDING, WITHOUT 
LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE), AND WHETHER ARISING UNDER COURSE OF 
PERFORMANCE, COURSE OF DEALING OR TRADE USAGE.

This Warranty is exclusive and limited to repair or, at the discretion of Banner Engineering Corp., replacement. IN NO EVENT SHALL BANNER ENGINEERING 
CORP. BE LIABLE TO BUYER OR ANY OTHER PERSON OR ENTITY FOR ANY EXTRA COSTS, EXPENSES, LOSSES, LOSS OF PROFITS, OR ANY 
INCIDENTAL, CONSEQUENTIAL OR SPECIAL DAMAGES RESULTING FROM ANY PRODUCT DEFECT OR FROM THE USE OR INABILITY TO USE THE 
PRODUCT, WHETHER ARISING IN CONTRACT OR WARRANTY, STATUTE, TORT, STRICT LIABILITY, NEGLIGENCE, OR OTHERWISE.

Banner Engineering Corp. reserves the right to change, modify or improve the design of the product without assuming any obligations or liabilities relating to any 
product previously manufactured by Banner Engineering Corp. Any misuse, abuse, or improper application or installation of this product or use of the product for 
personal protection applications when the product is identified as not intended for such purposes will void the product warranty. Any modifications to this product 
without prior express approval by Banner Engineering Corp will void the product warranties. All specifications published in this document are subject to change; 
Banner reserves the right to modify product specifications or update documentation at any time. Specifications and product information in English supersede that 
which is provided in any other language. For the most recent version of any documentation, refer to: www.bannerengineering.com.

For patent information, see www.bannerengineering.com/patents.

http://www.bannerengineering.com
http://www.bannerengineering.com/patents
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