
Production Performance Monitoring Application Guide Introduction
Increase process awareness and begin monitoring manufacturing throughput with a wireless Production Performance Monitoring
(PPM) Kit from Banner Engineering. The PPM Kit is a modular self contained solution that can be used to monitor up to 47 lines or
processes using battery-powered Q45 All-in-One Photoelectric Sensor Nodes or DC-powered Wireless TL70 Tower Light Nodes for
use with already installed sensors. TL70 Tower Light Nodes can be equipped with lighted segments for local line speed indication
without any additional configuration.
This application enables quicker responses from line operators to increase production speeds when throughput rates are low, and
empowers process and automation engineers with real data for continuous improvement without the need to change any
programming on their production process.
This application guide demonstrates how to bind the Wireless Q45 All-in-One Photoelectric Sensor Nodes and Wireless TL70 Tower
Light Nodes to the DXM Controller and how to load the pre-configured XML and ScriptBasic files. Operators can quickly be up and
running by entering line speed information directly into the DXM using the built-in screen and buttons. The system can be further
customized for specific application requirements.

Guide Features and Benefits

Performance Calculations Calculates line performance by comparing the actual line throughput to a user-defined ideal state

Part Counting Use up to 47 battery-powered Q45 All-in-One Photoelectric Sensor Nodes or Wireless TL70 Tower Light Nodes for part
counting up to 960 parts per minute

Track line speeds Calculates the parts per minute rates for each sensor and gives the instantaneous rate and a daily averaged rate

Monitors Machine Status Determines line status (running, slow, or stopped) based on user-defined throughput rates; tracks changes of event and
monitors length of events

Status Alerting User-configured alert settings for extended slow or stopped conditions

Remote Monitoring Pushes data to Banner's Cloud Data Services for remote viewing, generating automatic dashboards, generating alerts, and
logging data

Equipment
Users can order a Production Performance Monitoring Kit that includes the base hardware for the solution and can expand it by
adding additional Q45 All-in-One Photoelectric Sensor Nodes and/or Wireless TL70 Tower Light Nodes. The pre-configured PPM Kit
comes with a single DXM1200 and one Q45 Sensor Node and/or TL70 Node. Users can also build their own kit and manually
configure the solution.
Table 1: Pre-configured kit models and components

Model Frequency Sensing Mode Kit Components

PPM-DKIT-9 900 MHz ISM Band

Diffuse

DXM1200-B1R1-812310 Wireless Controller

DX80N9Q45DD All-in-One D Cell Sensor Node
PSW-24-1 Power Supply, LMB30LP bracket, and a 90-day trial for Banner CDS

PPM-DKIT-2 2.4 GHz ISM Band
DXM1200-B1R3-812311 Wireless Controller

DX80N2Q45DD All-in-One D Cell Sensor Node
PSW-24-1 Power Supply, LMB30LP bracket, and a 90-day trial for Banner CDS

PPM-LPKIT-9 900 MHz ISM Band

Retroreflective

DXM1200-B1R1-812310 Wireless Controller

DX80N9Q45LPD All-in-One D Cell Sensor Node
PSW-24-1 Power Supply, LMB30LP bracket, BRT-2X2 reflector, and a 90-day trial for Banner CDS

PPM-LPKIT-2 2.4 GHz ISM Band
DXM1200-B1R3-812311 Wireless Controller

DX80N2Q45LPD All-in-One D Cell Sensor Node
PSW-24-1 Power Supply, LMB30LP bracket, BRT-2X2 reflector, and a 90-day trial for Banner CDS

PPM-TLKIT-9 900 MHz ISM Band

Wireless Node
only - requires a
PNP sensor

DXM1200-B1R1-812310 Wireless Controller

B-TL70DXN9-Q5 Wireless Base Module
PSW-24-1 Power Supply (qty 2), S15A-F1235X-M123X4-Q adapter, CSB-M1250M1250-T splitter, LMB30LP bracket
and a 90-day trial for Banner CDS

PPM-TLKIT-2 2.4 GHz ISM Band

DXM1200-B1R3-812311 Wireless Controller

B-TL70DXN2-Q5 Wireless Base Module
PSW-24-1 Power Supply (qty 2), S15A-F1235X-M123X4-Q adapter, CSB-M1250M1250-T splitter, LMB30LP bracket
and a 90-day trial for Banner CDS
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Build your own Kit— Users can build their own kit and customize individual component choices.
1. Select what radio frequency can be used:

900 MHz
2.4 GHz

2. Select a DXM Controller/gateway/Edge device:
DXM700
DXM1000
DXM1200

3. Select how many lines are being monitored (Number of Nodes) and what sensor is suitable for monitoring. Any combination
of the following devices is compatible with the PPM Kit:

Diffuse
Retroreflective
Tower Light Node for use with any PNP sensor

4. Add optional accessories as needed
Refer to Table 2 on p. 2 for suggested models and to Optional Accessories on p. 2 for suggested brackets, power supplies,
and cables.
Table 2: Solution components

Model
Description

900 MHz 2.4GHz

DXM1200-B1R1 DXM1200-B1R3 DXM Series Wireless Controller, system compatible with DXM700, DXM1000, or DXM1200 Wireless Controllers

DX80N9Q45DD DX80N2Q45DD Wireless All-in-One D Cell Photoelectric Diffuse Sensor Node

DX80N9Q45LPD DX80N2Q45LPD Wireless All-in-One D Cell Photoelectric Retroreflective Sensor Node

B-TL70DXN9-Q5 B-TL70DXN2-Q5 TL70 Wireless base module for PNP sensors

Optional Accessories

Accessory Model Description

SG-TL70-G Green TL70 Wireless Base Segment for Status Indication

SG-TL70-Y Yellow TL70 Wireless Base Segment for Status Indication

SG-TL70-R Red TL70 Wireless Base Segment for Status Indication

TL70DXN9GYRQ TL70 Wireless Tower Light with counter input, 900 MHz

TL70DXN2GYRQ TL70 Wireless Tower Light with counter input, 2.4 GHz

PSW-24-1 DC power supply with wall plug, 100-240 V AC 50/60 Hz input, 24 V DC 1 A output, UL Listed Class 2
(comes with kit, power supply for the DXM controller and TL70)

S15A-F1235X-M123X4-Q S15A In-Line Adapter for adapting sensor output (black wire/pin 4) to TL70 input wire (gray wire/pin 5)

CSB-M1250M1250-T M12 straight T splitter connector for use with TL70 and S15A In-Line Adapter

LMB30LP Low-profile mounting bracket for Q45s and TL70 Wireless Base Segment
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Accessory Model Description

SMB30A Right-angle Mounting Bracket for Q45s and TL70 Wireless Base Segment

BRT-2X2 Retroreflector, square 51 mm × 51 mm for use with Q45 Retroreflective All-in-One Sensor Node

BWA-BATT-011 3.6 V Lithium D Cell Replacement Battery

Step 1: Set the DIP Switches
The Q45 All-in-One Photoelectric Sensor Nodes and WirelessTL70 Tower Light Node require specific DIP switch settings to operate
correctly with the PPM Kit.
Table 3: DIP switch positions

Model DIP Switch 1 DIP Switch 2 DIP Switch 3 DIP Switch 4

Q45DD and LPD All-in-One
Nodes

OFF OFF ON OFF

TL70 Tower Light Node OFF OFF ON OFF

For detailed instructions about how to access the DIP switches, refer to the Q45DD and LPD datasheet (p/n 223998) and the
Wireless TL70 Tower Light Node datasheet (p/n 185469).
After making changes to the DIP switches, cycle power to the Q45s and/or the TL70. To cycle the power to any battery-powered
radios, enter binding mode and then exit binding mode (with or without binding). For instructions on how to enter/exit binding mode,
see Step 2: Bind the Q45 and Tower Light Nodes on p. 3.

Step 2: Bind the Q45 and Tower Light Nodes
The binding process establishes a secure radio connection between the Nodes and the DXM Controller. Follow these steps to bind
the Q45 All-in-One Photoelectric Sensors and/or TL70 Nodes to your DXM Controller.
Before beginning the binding procedure, apply power to all the devices.

1. On the DXM: Enter binding mode by going to the Main menu and selecting ISM Radio > Binding.
2. Select the Node ID you would like to assign to the Q45 or TL70 Node.

Assign each Node a unique Node ID. Node IDs 1 through 47 are the valid selections. Banner Engineering recommends
binding Nodes in order (Node 1, Node 2, etc).

3. Press Enter to start the binding procedure.
4. Enter binding mode on a Q45 or TL70.

• On the Q45 All-in-One Photoelectric Sensors: Access the binding button by unscrewing and lifting the plastic cover.
Press the binding button three times.

• On the TL70: Access the binding button by holding the base module and twisting the cover counter-clockwise and pulling
the cover off. Press the binding button three times.

The red and green LEDs flash alternately and the radio searches for a DXM in binding mode. After the device is bound, the
LEDs stay solid momentarily (appears orange), then flash four times. The radio exits binding mode.

5. Label the Node's ID number with the supplied Device ID sticker.
6. On the DXM: Press Back to return to the Bind to # screen.

If the Node is bound and synchronized with the DXM, the green status LED flashes.
7. Repeat these steps for as many Nodes as are needed for your network.
8. After binding all Nodes, exit binding mode on the DXM by pressing Back until you return to the Main menu.

Step 3: Conduct a Site Survey from the DXM
Conduct a Site Survey to verify the wireless communication between the radios within your wireless network. Conduct the site
survey when the Nodes and DXM Controller are at the proposed installation sites to determine each radio's signal strength with the
DXM.

1. On the DXM: Use the arrow buttons to select the ISM Radio menu and press ENTER.
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2. Select the Site Survey menu and press ENTER.
3. Use the Up or Down arrows to select the device ID number and press ENTER to run the site survey with that radio.

The site survey results display as green, yellow, red, and missed packets. Green indicates the highest signal strength, then
yellow, and red. Missed packets were not received.

4. When you are finished running the Site Survey, press Back twice to return to the main menu and exit site survey mode.
If the Site Survey fails (100 missed packets), verify the radios are at least 10 feet from the DXM and/or rerun the binding procedure.
If you find poor signal quality, common solutions include moving the DXM to a more central location relative to the Nodes or using
higher-gain antennas on the DXM. Contact your local Banner Engineering representative for assistance.

Step 4: Upload the Configuration Files
There are two files loaded onto the DXM: the XML configuration file that defines the DXM's Local Register configuration and the
ScriptBasic file that runs the main program. Skip these instructions and to go Step 5: Configure the Application Settings on p.
4 if your DXM1200 is pre-loaded with the XML and ScriptBasic files. The DXM1200 that comes in the PPM Kits is pre-
loaded with the files.
Verify you have run the binding instructions on all Nodes, assigned Node IDs to all radios, installed the radios, and conducted a Site
Survey to test the signal strength.

1. Download and install Banner's DXM Configuration Software (v4 or newer) onto the computer you will be using to configure
your files.

2. Download the Production Performance Monitoring Kit configuration files (p/n b_51144830) from 
www.bannerengineering.com. The pre-configured files can also be found on the DXM Series Page or the Production
Performance Monitoring application guide page.

3. Extract the ZIP files into a folder on your computer. Note the location where the files were saved.
4. Connect the DXM, using the USB Cable supplied or with an Ethernet cable, to a computer containing the DXM Configuration

Software V4.
5. Launch the configuration software and connect to the DXM.
6. In the Configuration Mode drop-down list, select Traditional Setup.
7. Select the connection mode.

• Serial—Select the COM port the USB cable is plugged into. If you are unsure which COM port to select and multiple
ports are listed, disconnect the USB cable and press the refresh button to see which port disappears. Reconnect the
USB cable and select the COM port that reappeared.

• TCP/IP—Enter the IP address of the DXM, which can be found in the DXM LCD under System Info > Ethernet > IP.
The default static IP is 192.168.0.1. Your computer must be on the same network as the DXM.

8. In the Select DXM Model drop-down list, select DXM1200.
9. Click Connect.
10. To load the configuration file, go to File > Open and choose the XML file 223065.xml.
11. To load the ScriptBasic file, go to Settings > Scripting and click Upload File. Select the ScriptBasic file 223064.sb.
12. On the menu bar, go to DXM > Send Configuration to DXM.

The XML configuration file uploads to the DXM and runs the PPM program after the DXM is rebooted.
13. Cycle power to the DXM Controller.

Step 5: Configure the Application Settings
After uploading the configuration file to the DXM, users can modify application-specific settings directly from the DXM's menu
system. Before making any changes, enable the Delay Mode via the DXM display. The PPM Kit is pre-configured to work without
additional complex programming or software. For the most accurate performance metrics, we recommend that users modify the
Number of Sensors, Ideal Run Rate, and Stopped Rate parameters to fit their specific production speeds.

1. On the DXM, use the arrow keys to select the Registers menu and press ENTER.
2. Scroll down to Delay Mode and press ENTER.
3. Using the arrow keys, change the value to 1 and press ENTER three times.

The Delay Mode setting should now display ON.
4. Use the arrow keys to modify any parameters based on the application/user requirements. See the Parameters table for

parameters that are configuration using the display.
a) Set the Number of Sensors to the number of Q45 or TL70 devices in the system. For increased processing speed and

reduced data pushed to the cloud, do not set this value higher than the actual number of devices in the network.
b) Set the Ideal Run Rate to the ideal line speed in parts per minute (PPM). The sensor will be in an ideal run state when

the PPM is above this parameter. When the PPM value is below this parameter, the sensor is in a slow running
condition. This parameter applies to all connected sensors. For individual Ideal Cycle Time parameters, set this value to
0 and modify registers 7051 and greater (not configurable with the display).

c) Set the Stopped Rate to the line speed in parts per minute (PPM) at which the process is considered stopped. The
sensor will be in a stop condition when the PPM value is less than this parameter. This parameter applies to all
connected sensors. For individual Stop Cycle Time parameters, set this value to 0 and modify registers 7101 and greater
(not configurable with the display).
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5. After all the application settings changes are entered, disable Delay Mode by setting the Delay Mode value to 0.
6. Cycle power to the DXM to apply your changes.

Table 4: Parameters

DXM
Registers

Name Description Default Value Cloud

851 Report Time
Global setting for Sensor report time in seconds, for Battery powered applications, it is not
recommended to report faster than 1/minute, longer report times increase battery life.

Set to 0 to use individual line report times. See register 7001

60 At boot/write

852 Number of Sensors
Indicates the number of Sensors in the system. The system cannot exceed 47 Sensors and can be a
combination of Q45s or TL70s

47 At boot/write

853 Ideal Run Rate
Global setting for an ideal run rate in parts per minute (PPM).

Set to 0 to use individual line Ideal Run Rates. See register 7051
15 At boot/write

854 Stopped Rate
Global setting for a stop condition in parts per minute (PPM).

Set to 0 to use individual stopped line rates. See register 7101
3 At boot/write

855 Slow Alarm Time Global setting, in seconds, for initiating a slow state alarm 300 At boot/write

856 Stop Alarm Time Global setting, in seconds, for initiating a stop state alarm 150 At boot/write

857 Stop Count
Successive reports below stopped rate to trigger a stopped scenario. For example, a stop count of three
(3) with a report time of 60 seconds means a line will not enter a stop state until it has been below the
Stopped Rate for three consecutive reports or 3 minutes

3 At boot/write

858 Delay Mode

Enables script delay that adds a two second wait time before starting another loop in the program, the
system operates normally with this exception. This is helpful for troubleshooting the system and should
be disabled during normal operation.

1 = Enabled, 0 = Disabled

0

859 Push Rate Global setting, in seconds, for initiating a push rate to Banner CDS. 300 1/day

860 Push Enable Enables the controller to push data to Banner CDS. Set to a value of 0 to disable cloud pushing 1

861 Low Performance
Global setting for a Low Performance Alert.

Set to a value of 0 to use individual Low Performance Alerts. See register 7151
85 At boot/write

862 Critical Performance
Global setting for a Critical Performance Alert.

Set to a value of 0 to use individual Critical Performance Alerts. See register 7201
50 At boot/write

Step 6: Push Information to BannerCDS
The DXM Wireless Controller can connect to the Web via Ethernet or an internal cell module. The controller pushes data from the
DXM to be stored and displayed on a website.
The Banner website for storing and monitoring the system's data is https://bannercds.com. The Banner Cloud Data Services website
automatically generates dashboard icons and graphs for the application that is populated onto the Dashboard. Email alerts can be
configured using the Alarms screen.

Create a New Gateway
After you log into the Banner CDS website, the Gateway screen displays. Follow these steps to create a new monitoring site.

1. Click on +New Gateway.
Create a new Gateway/site for each device that will be sending data to the web server.

Figure 1. Create a New Gateway/Site

A Create New Gateway prompt appears.
2. Verify Traditional is selected for the Configuration.
3. Enter a site name.
4. Under XML Config, select Choose File and upload the PPM configuration XML file: 223065.xml.
5. When prompted to generate a unique gateway ID, click Yes and then click Get XML when prompted to download the file.

This generates a unique ID that needs to be loaded back into the DXM. Save this file for the next step.
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6. Click Create.
The Gateway/Site appears in the listing of devices on the Gateways screen and lists a status of Waiting for device to
connect. After the DXM begins pushing data, the status changes to a green timestamp after a successful push.

Update the DXM with the Banner CDS Configuration
The DXM is automatically configured to push data to Banner CDS at 5 minute intervals. No additional configuration changes are
required after downloading the modified XML that was created for this application.

1. Within the DXM Configuration Software, connect to the DXM and go to the File > Open menu. Open the XML configuration
file downloaded from Banner CDS for this application.

2. Send the updated XML to the DXM Controller using the DXM > Send XML Configuration to DXM menu.
Completing these steps creates continuity between the site created on the website with the DXM used in the field. The DXM pushes
data to the website, which can be viewed at any time.

Figure 2. Main dashboard screen

Refer to the Banner Cloud Data Services Instruction Manual to review all the features available for monitoring, comparing data, and
establishing warnings/alarms on the website. To access a demo version of the website please contact your local Banner distributor
and follow the instructions in the technical note: Connecting to the Banner Cloud Data Services Demo Site for modified instructions
on how to send data to the demo site.

Dashboard View
The PPM Kit automatically creates two dashboards for performance monitoring. The main dashboard gives users a high level view
of the system, showing the total slow and stop events and average length of events across the entire system of sensors. Individual
item view dashboards give users access to view individual sensor performance, part counts, status, average ppm, and the ability to
configure individual sensor settings such as run rates, stop rates, and performance thresholds.

Figure 3. Item View dashboard screen for the PPM kit

  Production Performance Monitoring (PPM) Application Guide

6 www.bannerengineering.com - Tel: +1-763-544-3164 P/N 223067 Rev. A

http://info.bannerengineering.com/cs/groups/public/documents/literature/178337.pdf
http://info.bannerengineering.com/cs/groups/public/documents/literature/b_4476257.pdf


Optional Configuration Steps

Clear the Sensor Data from the DXM
The Sensor Data, State, and Timer registers in the system have a reset register that can be accessed using the DXM's display,
Modbus Registers, or Banner CDS. Set register 822 to a value of 1 to reset all the counters and data registers.
Follow these steps to clear the sensor data using the DXM display.

1. On the DXM: Use the arrows to select Registers.
2. Select the Clear Sensors register.
3. Press Enter.
4. Change the value to 1 then press Enter three times.

The reset register automatically returns to zero after the data is reset.

Clear the Sensor Data from Banner CDS
Follow these steps to clear the sensor data using the Banner Cloud Data Services website.

1. Go to the Dashboard > Sites screen.
2. Select the Dashboard name where the Call for Parts Kit exists.
3. Toggle the Clear Sensors button.
4. A pop-up window asks if you would like to trigger an update. Click Yes.

An update to reset the data registers is sent to the DXM the next time the DXM pushes data to Banner CDS.

Clear the Sensor Data from the Scheduler Tool
The Sensor Data can be cleared using the DXM Configuration Software's Scheduler tool.
Synchronize the DXM's on-board clock with your PC for accurate scheduled resets. To sync the PC time with the DXM, go to
Settings > System and click Sync PC time with device.

1. In the DXM Configuration Software: Load the PPM configuration XML file (223065.xml).
2. Go to Tools > Scheduler > Weekly Events and click Add Weekly Event.
3. Name the event and set the Register to 822. Register 822 is the Clear Sensors register.
4. Select the days that the reset will be conducted, the abbreviations will be highlighted yellow when selected.
5. Set the Schedule Definition parameters.

a) Set the Start Value to 1.
b) In the Start at drop-down list, select Specific Time.
c) Set the desired reset time using 24-hour format.
This can be repeated multiple times for automatic shift resets. An End Value is not required for this functionality.

6. Go to File > Save to save the changes to your configuration file.
7. Go to DXM > Send Configuration to DXM to upload the new configuration file to the DXM.

Set Individual Report Rates
Sensor report rates can be customized to have individual reporting (such as some sensors reporting once every minute and others
every 5 minutes). For this advanced setting, the DXM must be accessed using the DXM Configuration Software, Banner CDS, or
Industrial protocols (Modbus TCP/Ethernet IP).

1. On the DXM: Use the arrows to select Registers.
2. Select the Report Time register and press Enter.
3. Change the value to 0 then press Enter three times.
4. Access the Individual Report Time registers (7001 through 7050).

a) When you are connected through the DXM Configuration Software, go to Tools > Register View > Writer Registers.
Set the Starting Register to 7001. Enter a value, in seconds, and click Write registers. The individual Report Time
registers can be updated one by one or in batches.

b) When you are connected through Banner CDS, go to the Data screen and find register 7001, Report Time N#. Click the
update icon on the left, enter the time in seconds, and click Save. The parameter will update on the next push to Banner
CDS.

c) When you are using industrial protocols, update the DXM's Local Registers 7001–7050 to reflect the individual Report
Time desired for each sensor.

5. After the Report Time parameter is updated, cycle the power to the DXM or set the Initialize command to 1 to update the
parameters on each sensor.
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Configure the Kit for a Cellular Push Interface
By default, the DXM in the Production Performance Monitoring kit is configured for an Ethernet push interface to push information to
Banner CDS. To configure the system for a cellular push interface, configure the default configuration file (223065.xml) for cell
capabilities. Cellular cloud connectivity requires an appropriate cellular modem and cell plan for the DXM1200.

1. In the DXM Configuration Software: Load the PPM configuration XML file (223065.xml).
2. Go to the Settings > Cloud Services screen and select Cell in the Push Interface drop-down list. If you are changing the

configuring from Cell to Ethernet, select Ethernet and go to step 4.
Setting the cloud push interval is not required; the PPM ScriptBasic file controls the cloud push rate.

3. In the Settings > Cellular screen, select the appropriate Cell Module that is connected to your DXM from the drop-down list.
4. Go to File > Save to save the changes to your configuration file.
5. Go to DXM > Send Configuration to DXM to upload the new configuration file to the DXM.

Interpreting the Status Registers
The Q45 All-in-one Photoelectric Sensor Nodes and Wireless TL70 Tower Light Nodes contain virtual status registers. These
registers can be used to determine what state each line is in and to calculate advanced metrics.
Registers 5951 through 6000 contain the status registers. The register's value determines what state the line is in. Users can map
this information to a PLC, HMI, or SCADA system for advanced analytics such as monitoring average slow/stop rates or monitoring
stop events.
Table 5: Sensor state and timers

DXM Registers Name
Register

Value
Status Description Cloud

5951–6000 Sensor State N#

100 Off Sensor/Node is powered on but has not begun counting

R/W

200 Run Sensor is in a run state condition, line speed is greater than Ideal Run Rate setting

300 Slow Sensor is in a slow state condition, line speed is less than Ideal Run Rate

400 Stop
Sensor is in a stop state condition, line speed is less than or equal to the Stopped
Rate

Local Registers
Table 6: Supervisory data

DXM
Registers

Name Description Cloud

801 Global Run State
At least one line is in a Run state, OR'd value of all sensors.

1 = true
R/W

802 Global Slow State
At least one line is in a Slow state, OR'd value of all sensors.

1 = true
R/W

803 Global Stop State
At least one line is in a Stop state, OR'd value of all sensors.

1 = true
R/W

804 Total Slow Events Sum of all Slow Counters for all sensors R/W

805 Total Stop Events Sum of al Stop Counters for all sensors R/W

806 Average Slow Time Average time of all slow events (minutes) for all sensors, total slow time divided by total slow events R/W

807 Average Stop Time Average time of all stop events (minutes) for all sensors, total stop time divided by total slow events R/W

808 Total Slow Time Sum of all slow times for all sensors R/W

809 Total Stopped Time Sum of all stopped times for all sensors R/W

810 Global Low Performance
At least one Sensor has a Low Performance Alert, OR'd value of all sensors.

1 = true
R/W

811 Global Critical Performance
At least one Sensor has a Critical Performance Alert, OR'd value of all sensors.

1 = true
R/W
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Table 7: Commands

DXM
Registers

Name Description Default Value Cloud

821 Initialize
Reads all parameter settings, generates node IDs and clears counters.

Set to 1 to initiate. Initializing should be executed when the Report Time or Number of Sensors Parameter
is Changed

0 At boot/write

822 Clear Sensors Clears all Sensor Data registers and Sensor States and Timers 0 At boot/write

823 Sync Sensors
Synchronizes Sensors to network (use when Sensor is powered ON but status is not 128). This is
generally used at startup/when initializing the system

0

Table 8: Parameters

DXM
Registers

Name Description Default Value Cloud

851 Report Time
Global setting for Sensor report time in seconds, for Battery powered applications, it is not
recommended to report faster than 1/minute, longer report times increase battery life.

Set to 0 to use individual line report times. See register 7001

60 At boot/write

852 Number of Sensors
Indicates the number of Sensors in the system. The system cannot exceed 47 Sensors and can be a
combination of Q45s or TL70s

47 At boot/write

853 Ideal Run Rate
Global setting for an ideal run rate in parts per minute (PPM).

Set to 0 to use individual line Ideal Run Rates. See register 7051
15 At boot/write

854 Stopped Rate
Global setting for a stop condition in parts per minute (PPM).

Set to 0 to use individual stopped line rates. See register 7101
3 At boot/write

855 Slow Alarm Time Global setting, in seconds, for initiating a slow state alarm 300 At boot/write

856 Stop Alarm Time Global setting, in seconds, for initiating a stop state alarm 150 At boot/write

857 Stop Count
Successive reports below stopped rate to trigger a stopped scenario. For example, a stop count of three
(3) with a report time of 60 seconds means a line will not enter a stop state until it has been below the
Stopped Rate for three consecutive reports or 3 minutes

3 At boot/write

858 Delay Mode

Enables script delay that adds a two second wait time before starting another loop in the program, the
system operates normally with this exception. This is helpful for troubleshooting the system and should
be disabled during normal operation.

1 = Enabled, 0 = Disabled

0

859 Push Rate Global setting, in seconds, for initiating a push rate to Banner CDS. 300 1/day

860 Push Enable Enables the controller to push data to Banner CDS. Set to a value of 0 to disable cloud pushing 1

861 Low Performance
Global setting for a Low Performance Alert.

Set to a value of 0 to use individual Low Performance Alerts. See register 7151
85 At boot/write

862 Critical Performance
Global setting for a Critical Performance Alert.

Set to a value of 0 to use individual Critical Performance Alerts. See register 7201
50 At boot/write

Table 9: Sensor data

DXM
Registers

Name Description Cloud

5001–5050 Part Count N# Part Count for each sensor R/W

5051–5100 Parts Per Minute (PPM) N#
Current line speed for each sensor. Calculated as the difference between the current count and last count
averaged over 1 minute

R/W

5101–5150 Average PPM N# Averages PPM values since last reset/count clear R/W

5151–5200 Ideal Run Rate Deviation N# Percent offset of Ideal Run Rate using Average PPM. Reported as a signed 32 bit value R/W

5201–5250 Last Count N# Last reported count value, non-cumulative R/W

Table 10: Sensor state and timers

DXM
Registers

Name Description Cloud

5501–5550 Sync Status N# Alarm for Sensor out of sync condition. Value of 0 = Out of sync, Value of 128 = sensor in sync R/W
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DXM
Registers

Name Description Cloud

5551–5600 Total Ideal Run Time N# Total Time (Seconds) that the Sensor is in a Run State condition. R/W

5601–5650 Total Slow Time N# Total Time (Seconds) that the Sensor is in a Slowed State condition. R/W

5651–5700 Total Stop Time N# Total Time (Seconds) that the Sensor is in a Stopped State condition. R/W

5701–5750 Total ON Time N# Total Time (Seconds) that the Sensor is ON, sum of Ideal Run Time, Slow Time, and Stop Time R/W

5751–5800 Average Slow Time N# Average Time (Seconds) that the Sensor is in Slow State conditions R/W

5801–5850 Average Stop Time N# Average Time (Seconds) that the Sensor is in Stop State conditions R/W

5851–5900 Slow Event Count N# Number of Slow State events R/W

5901–5950 Stop Event Count N# Number of Stop State events R/W

5951–6000 Sensor State N# Current Status of the Sensor, 100 = OFF, 200 = Run, 300 = Slow, 400 = Stop R/W

6001–6050 Sensor Running N# Sensor is in a run state condition. Value of 1 = Run

6051–6100 Sensor Slowed N# Sensor is in a slow state condition. Value of 1 = Slow

6101–6150 Sensor Stopped N# Sensor is in a stop state condition. Value of 1 = Stopped

6151–6200 Availability N# Sensor Availability calculated as (Ideal Run Rate Time + Slow Time) / Total ON Time R/W

6201–6250 Performance N# Sensor Performance calculated as (Part Count/Total ON Time)/Ideal Run Rate R/W

6251–6300 Low Performance Alert N# Individual Sensor Low Performance Alert. 1 = Alert Active

6301–6350 Critical Performance Alert N# Individual Sensor Critical Performance Alert. 1 = Alert Active

6901–6950 Clear Count N# Clears the Sensor States and Counter information for the designated node ID At Boot/Write

Table 11: Individual parameters

DXM
Registers

Name Description Cloud

7001–7050 Report Time N# Individual Sensor report Times (seconds), only enabled if register 851 = 0 At Boot/Write

7051–7100 Ideal Run Rate N# Individual Sensor Ideal Run Rate (PPM), only enabled if register 855 = 0 At Boot/Write

7101–7150 Stopped Rate N# Individual Sensor Stopped Rate (PPM), only enabled if register 856 = 0 At Boot/Write

7151–7200 Performance Low N#
Individual Sensor Low Performance Setting (Percent), will only be enabled if register " " = 0.

Valid settings are between 0 and 100.
At Boot/Write

7201–7250 Performance Critical N#
Individual Sensor Critical Performance Setting (Percent), will only be enabled if register " " = 0.

Valid settings are between 0 and 100.
At Boot/Write
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