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Loading Dock and Mobile Pick-
Up Application Guide

Equipment

Guide Features and Benefits
VEHICLE DETECTION Monitor up to 24 M-GAGE sensors, U-GAGE sensors, or a combination of both to detect vehicle presence

INDICATION Indicate vehicle presence on up to four wireless TL70s with each location turning on one of six light modules on 
each wireless TL70

EVENT COUNTERS Count the number of times each location detected vehicle presence

TOTAL AND AVERAGE TIME Track total time at each location and calculate average time at each location using the count

EXTENDED TIME INDICATION User configurable setting to indicate an extended vehicle presence by changing the solid light on the wireless TL70 
to a flashing light

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on specific events

CLOUD MONITORING Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, alerting, and logging.

This guide provides the ability to monitor and track a combination of up to 24 M-GAGEs or U-GAGEs through the DXM100 while providing 
indication through up to four wireless TL70 tower lights with six light segments on each. 

Each time a presence is detected, a corresponding tower light segment illuminates and after an optional user-configurable number of minutes 
changes from a solid light to a flashing light. The DXM tracks the total time of all vehicle presence, a count the vehicles detected, the average 
time of vehicle presence, and a current time of vehicle presence that resets to zero upon the vehicle leaving. The local light indication can save 
time and money when action is required upon a vehicles arrival. It can also provide overall metrics to track and improve performance of the 
actions being taken. Application examples include loading docks and mobile pick-up areas.

A PDF of this Application Guide is available at https://goo.gl/WMOZHR

Model Description

TL70DXN9XXXQ or TL70DXN2XXXQ
(XXX is any combination of light colors)

EZ-LIGHT TL70 Wireless Modular Tower Light; select either 900 MHz or 2.4 GHz ISM radio to 
match the DXM100

DXM100-B1C1R1 or DXM100-B1C1R3 DXM100 Wireless Controller with Cell; select either 900 MHz or 2.4 GHz ISM radio to match the 
M-GAGEs or U-GAGEs; C1 only necessary if Cell Module is desired

DX80N2X1W0P0ZT or DX80N9X1W0P0ZT Wireless M-GAGE; select either 900 MHz or 2.4 GHz ISM radio to match the DXM100; Optional 
“D” on part name for D Cell Battery

DX80N2X1W0P0U or DX80N9X1W0P0U Wireless Ultrasonic U-GAGE; select either 900 MHz or 2.4 GHz ISM radio to match the DXM100

BWA-MGFOB-001 Optical Commissioning LED Tool for M-GAGEs and U-GAGEs
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The following guide demonstrates how to bind the wireless M-GAGEs, U-GAGEs, and TL70s to the DXM and load a preconfigured XML 
file and script for up to 24 vehicle detection spots with indication on up to four wireless TL70s. The XML file only requires some minor 
modifications to be customized for any site.

Step 1: Bind the System and Assign Addresses
Bind the M-GAGEs and/or U-GAGEs and TL70 to the DXM100 to establish a secure connection and assign the Nodes a network address. 
The first 24 Nodes in the system are reserved for binding the M-GAGEs and/or U-GAGEs. The remaining four lights must be bound to 
addresses 25–28. Each light segment on the TL70 will be associated with specific Node IDs. The first six Node IDs correlate to the first six light 
segments on the first TL70. Label the M-GAGEs and/or U-GAGEs with their Node IDs for proper installation with their associated TL70.

When operating at 900 MHz, these devices must transmit at 250 mW to communicate with the M-GAGEs and/or U-GAGEs. To transmit at 
250 mW, change DIP switch 1 on the TL70s and the DXM ISM Radio to the ON position.

To change the DXM ISM Radio to 250 mW, remove the top cover, remove the processor board, and on the ISM radio move DIP switch D1-1 
ON. Refer to the DXM datasheet for detailed instructions.

To change the Wireless TL70 to 250 mW, remove the TL70 base from any light segments and move DIP switch 1 to ON. Leave the base 
detached for binding. Refer to the TL70 Wireless Tower Light datasheet for detailed instructions.

Bind the M-GAGE and/or U-GAGE Radios
To bind the M-GAGE and/or U-GAGE radios to the DXM master radio:

1.	 Apply power to the DXM.
2.	 On the DXM: Use the arrow button to select the ISM Radio menu on the DXM’s LCD. Press Enter. 
3.	 Select Binding and press Enter.
4.	 Select Bind to > 1 (the first Node) and press Enter.
5.	 Wake up the M-GAGE or U-GAGE using the Optical LED tool. Click and hold the light on above the optical sensor on the Node until 

a red LED flashes indicating it is awake. Refer to the Node’s datasheet for more information.
6.	 On the M-GAGEs or U-GAGEs: Triple-click the Optical LED tool above the optical sensor on the device. 

The LED on the device flashes green and red. When the LED combines colors and flashes four times, the unit is bound to the DXM 
as Node ID 1. Label the Node for future reference.

7.	 On the DXM: Press Back to return to the main menu.
8.	 To bind additional M-GAGEs or U-GAGEs, select Bind to > X (where X is the next device in the network) and press Enter.
9.	 On the second M-GAGE or U-GAGE: Triple-click the LED tool above the optical sensor.

If more M-GAGEs or U-GAGEs are being used in the system, continue binding until all GAGEs are bound to the DXM with unique Node IDs. 
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Step 2: Configure the System
To customize the system to an actual application, make some basic modification to the template files. There are two files uploaded to the 
DXM: the XML file sets the DXM’s initial configuration and the ScriptBasic file looks for vehicle presence, tracks the times and counts of the 
vehicle presence, outputs vehicle presence to the TL70 light, creates a teach function via the DXM display, creates a reset function via the 
DXM display for timer and count resets, and organizes the information in registers in the DXM.

Loading these files and making adjustments requires using Banner’s DXM Configuration Tool software and the “Vehicle Detection…” files 
available using the links below.

1.	 Download the preconfigured files. (https://goo.gl/kvIiQj)
2.	 Extract the ZIP files into a folder on your computer. Note the location where the files were saved.
3.	 Connect the DXM, via the USB cable supplied with the DXM, to a computer containing the DXM Configuration Tool software or 

download the software and install it on a computer.
4.	 Launch the software.
5.	 Load the “Vehicle Detection…” XML file by going to the File > Load menu and choosing the configuration files.
6.	 Connect the software to the DXM by going to the Device > Connection Settings menu. Select Serial and then select the COM 

port that the USB cable is plugged into. Click Connect. If you are unsure which COM port to select, and multiple appear, attempt to 
connect to each one of them until you are successful.

7.	 Upload the “Vehicle Detection…” script file by going to the Settings > Scripting screen. Click Upload Script and select the file.
8.	 Select the uploaded file in the window to the right of the Upload Script button. Click Add Selected to Startup; the DXM will run this 

script every time it restarts.
9.	 Save the XML file using the File > Save menu. Save the XML file any time the XML has been changed because the tool does not 

autosave.

Bind the TL70 Wireless Modular Tower Lights
Bind the wireless TL70 as Nodes 25–28 with ID 25 covering Nodes 1–6 and 28 covering Nodes 19–24.

1.	 Apply power the TL70s.
2.	 Apply power to the DXM.
3.	 On the DXM: Use the arrow button to select the ISM Radio menu on the DXM’s LCD. Press Enter.
4.	 Select Binding and press Enter.
5.	 Select Bind to > 25 (the first Node) and press Enter.
6.	 On the first TL70: With the base section removed,triple-click the binding button.

The LED flashes four times after it binds to the DXM. This Node is now bound as Node ID 25. Label the TL70 for reference.
7.	 Reconnect the TL70’s base to its light modules.
8.	 On the DXM: Press Back to return to the main menu.
9.	 To bind additional TL70s, select Bind to > 26 and press Enter.
10.	 On second TL70: Repeat steps 6 through 8. Continue binding TL70s lights until complete.
11.	 When you are finished binding, press Back on the DXM until the DXM returns to the main menu.

To complete the configuration of the TL70 light modules, each module has a DIP switch on the bottom of the light. The DIP switch in the ON 
position indicates which Node input with which it is associated (1–6). Typically, the modules are placed in order of 1 through 6 with 1 being the 
bottom light segment and 6 being the top segment. If you have fewer than six light segments on a TL70 your module may vary.

http://info.bannersalesforce.com/intradoc-cgi/nph-idc_cgi.exe?IdcService=GET_FILE&dDocName=b_4446613&RevisionSelectionMethod=Latest&Rendition=web
https://goo.gl/kvIiQj
http://info.bannersalesforce.com/intradoc-cgi/nph-idc_cgi.exe?IdcService=GET_FILE&dDocName=b_4207381&RevisionSelectionMethod=Latest&Rendition=web
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Optional Steps: Customize the XML file
1.	 Within the DXM Tool, go to the Local Registers > Local Registers in Use screen.
2.	 Rename the vehicle locations using the text boxes within the Register Name column. Because there are five registers per vehicle 

location, copy and paste names for efficiency.
To display the vehicle location status, count, or timer on the website, change the Cloud Permissions column drop-down lists to 
Read for each vehicle locations’ information piece (presence, timer, count, etc.) that you would like to appear on the website.

3.	 The file has a nightly scheduled time (3:00 AM) to re-teach/baseline the M-GAGE and/or U-GAGE Nodes. To adjust this time:
a.	 go to the Scheduler > Weekly Events screen. 

b.	 Click the arrow to expand the weekly event. 

c.	 Adjust the times accordingly with the start and end times being one minute apart. 

d.	 De-select any days you do not want the event to occur. 

e.	 Leave the register set as 301. The event can be deleted if no scheduled teaching/baselining is desired.

4.	 To display the statuses for each vehicle location on the website, change 
the cloud permissions.

a.	 On the Modify Multiple Registers screen, select Change in 
the drop-down list next to Cloud Permissions.

b.	 In the drop-down list to the right, select Read for Cloud 
Permissions.

c.	 Set the Starting Register to 1 and the Ending Register 
to the value equal to 5 × Number of vehicle locations in the 
system (for example, set the ending register 90 for 18 vehicle 
locations).

d.	 Click Change Registers on the bottom right of the section.
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5.	 Configure to Receive Email or Text Alerts based on an Action Rule.
a.	 Go to the Action Rules > Thresholds screen.

b.	 Expand any rule using the arrow next to the rule OR create a new action rule using the Add Threshold Rule button on the 
top.

c.	 Click on the arrow next to Email/SMS on State Transition.

d.	 Select the recipient of the SMS and/or email upon the action rule becoming true.

In the example shown, both SMS Recipient 1 and 2 and Email Recipient 1 and 2 will receive a message when the action rule meets 
its criteria.

Set up the Ethernet or Cellular Connection
By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data registers to 
a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and data plan. This 
section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1.	 If the DXM will text, email, or push to the cloud webserver, set up the push interface.
a.	 On the DXM Configuration Tool, go to the Settings > Cloud Services screen.

b.	 Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list.

Selecting Cell requires a cellular module be installed in the DXM Controller and a wireless plan be set up for sending data.
2.	 The Cloud Push Interval determines how often the DXM pushes the current status data to the webserver. By default, this interval is 

set to zero and should not be changed. If data is being pushed 
to the cloud, set the Cloud Push Interval to 00:15:00 (15 
minutes). 

3.	 Set up the email and text messages. SMS works only if the DXM 
has a cellular module. Expand the Email Recipients and SMS 
Recipients to enter up to 10 email addresses and 10 phone 
numbers, along with a custom message.

a.	 Go to the Settings > Mail and Messaging screen.

b.	 All SMTP fields should remain set to their default 
values, except the Password field. Enter “sxiemail1” 
into the Password field.

c.	 Click Send SMTP Password.

d.	 Click Yes when asked to reboot the device.
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Step 3: Save and Load the XML File
When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1.	 Save the file by going to the File > Save menu.
2.	 Load the file onto the DXM by going to the Device > Send Configuration to Device menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the 
Application Status indicator in the status bar.

If the Application Status indicator is red, close and restart the DXM Configuration Tool, unplug and re-plug in the USB cable and 
reconnect the DXM to the software. If the Application Status indicator is green, the file upload is complete. If the Application Status 
indicator is yellow, the file transfer is in progress.

Step 4: Run a Site Survey
Verify the wireless connection between your M-Gages and/or U-Gages, TL70s and the DXM by running a site survey on the DXM100.

1.	 On the DXM: Use the arrow buttons to select the ISM Radio menu and press Enter.
2.	 Select the Site Survey submenu and press Enter.
3.	 Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
4.	 When you are finished running the site survey, press Back twice to return to the main menu.

Step 5: Teaching the U-GAGE/Baselining the M-GAGE
All U-GAGEs must be taught where the floor is after the Nodes are installed. Each M-GAGE must be baselined for local magnetic fields after 
they are installed. Each vehicle location Node in the network has a Teach register that is available on the face of the DXM’s LCD and via the 
website. Setting this register to 1 baselines/teaches the unit of that particular Node as described on the datasheet.

Teaching from the DXM
1.	 On the DXM: Use the arrows to select Registers. The registers are labeled X Teach (where X is the Vehicle location ID you want to 

reset). There is a Teach All, which resets all statistics for each vehicle location.
2.	 Select the appropriate register to reset.
3.	 Click the Enter button.
4.	 Change the value to 1 then click Enter three times. The reset register automatically returns to zero after the register(s) reset.

Teaching from the Website
1.	 Go to the Dashboard > Sites screen.
2.	 Click Options for the site where the particular vehicle location exists. 
3.	 Click on the Update tab in the pop-up window that appears.
4.	 From the Type drop-down list, select Register.
5.	 From the Register Name drop-down list, select the vehicle location ID you want to reset.
6.	 Enter 1 into the Value field and click Queue.
7.	 Repeat steps 5 and 6 for each vehicle location that needs to be reset or use the Teach All register and follow steps 5 and 6.

When the next data push occurs, the chosen units reset. The reset registers automatically return to zero after the registers reset.
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Step 6: Push Information to the Cloud
The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to the cloud and display the data on a 
website. To enable this capability for remote monitoring and alarms settings, modify the XML file.

The Banner Cloud Data Services (BannerCDS) website for storing and monitoring the system's data is https://bannercds.com/.

1.	 Connect the DXM to a computer with the DXM Configuration Software.
2.	 Launch the software and connect to the DXM.
3.	 Load the saved XML file.
4.	 Go to the Settings > Cloud Services screen.
5.	 Visit the website and log into an existing account or register a new account.
6.	 Click + New Site and name your site.
7.	 Highlight and copy the Site ID.
8.	 On the DXM Configuration Tool: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.
9.	 Save the XML file (File > Save).
10.	 Upload the file to the DXM (Device > Send Configuration to the Device).
11.	 On the website: Click Options on the row of the newly created site. Click the checkbox next to XML Config and select the XML file 

that was just saved/uploaded to the DXM.
12.	 Click Save to complete the connection to the website.

This creates continuity between the site created on the website with the DXM used in the field. The DXM pushes data to the website, which 
can be viewed at any time. Refer to the Banner Cloud Data Services Instruction Manual to review all the features available for monitoring, 
comparing data, and establishing warnings/alarms on the website.

To access a demo version of the website please contact your local Banner distributor and follow the instructions in the technical note: 
Connecting to the Banner Cloud Data Services Demo Site for modified instructions on how to send data to the demo site.

https://bannercds.com
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Additional Features
Setting Extended Vehicle Presence Time
The user may configure a threshold time, in minutes, that when exceeded changes the vehicle presence indication of the TL70 from a solid 
light to a flashing light for module associated with that vehicle location.

To configure the extended vehicle presence threshold:

1.	 On the DXM: Use the arrows to select Registers. Scroll with the arrows to the Extended Time register.
2.	 Click the Enter button.
3.	 Set the threshold time, in minutes, then click Enter three times. This value is stored in non-volatile memory and remains after any 

power cycling.
4.	 Cycle power to the DXM.

To return to the system default Extended Time setting

1.	 Use the arrows to select Registers. Scroll down with the arrows to Initialize and click Enter. 
2.	 Change this value to 0 and click Enter three times.
3.	 Restart the DXM by cycling power to the device or from the main DXM menu, select System > Restart and click Enter.

Resetting the Timer and Counts
Each vehicle location in the system has a reset register that is available on the face of the DXM’s LCD and via the website. Setting this register 
to 1 resets all the counts and timers on that particular vehicle location.

Resetting from the DXM
1.	 On the DXM: Use the arrows to select Registers. The registers are labeled X Reset (where X is the Vehicle location ID you want to 

reset). There is a Reset All that resets all statistics for each vehicle location.
2.	 Select the appropriate register to reset.
3.	 Click the Enter button.
4.	 Change the value to 1 then click Enter three times. The reset register automatically returns to zero after the register(s) reset.

Resetting from the Website
1.	 Go to the Dashboard > Sites screen.
2.	 Click Options for the site where the particular vehicle location exists. 
3.	 Click the Update tab in the pop-up window that appears.
4.	 From the Type drop-down list, select Register.
5.	 From the Register Name drop-down list, select the vehicle location ID you want to reset.
6.	 Enter 1 into the Value field and click Queue.
7.	 Repeat steps 5 and 6 for each vehicle location that needs to be reset or use the Reset All register following steps 5 and 6.

When the next data push occurs, the chosen units will reset. The reset registers automatically return to zero after the register(s) reset.

Configuring Time Stamped Logging
To setup time-stamped logging, follow these steps.

1.	 Go to the Local Registers > Modify Multiple Registers screen.
2.	 Click Reset Form.
3.	 From the SD Card Logging drop-down list, select Change.
4.	 Select Log 1 in the drop-down list that appears to the right.
5.	 Set the Starting Register to 1 and the Ending Register to the value equal to 5 × Number of vehicle locations in the system (ex. 

Ending Register 90 for 18 vehicle locations). 
6.	 Click Change Registers.
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Local Registers
 Local Register # Description

Vehicle Detection Information

1 + 5 × (N − 1) Vehicle Presence (0=OFF/1=ON)

2 + 5 × (N − 1) Total Vehicle Presence Time (mins)

3 + 5 × (N − 1) Total Vehicle Presence Count

4 + 5 × (N − 1) Average Vehicle Presence Time (mins)

5 + 5 × N − 1) Current Vehicle Presence Time (mins)

M-GAGE/U-GAGE Node Read 121–144 Raw Input from M-GAGE or U-GAGE

Node Connection Status 145–172 GAGE and Light Connection Status

Extended Presence 250–273 Extended Vehicle Presence

Teach All 301 Teach/Baseline All GAGE Nodes

Teach 1–24 302–325 Teach/Baseline GAGE Nodes 1–24

Reset All 326 Reset All Vehicle Detect Registers

Reset 1–24 302–325 Reset Vehicle Detect Registers 1–24

Extended Time Setting 851 User Configurable Extended Time Setting

Initialize 852 Initialize DXM with Extended Time Setting

Retrieving a Log File
1.	 Connect the DXM to the computer via USB or Ethernet. Connect the DXM Configuration Software to the DXM using the

Device > Connection Settings menu.
2.	 Go to the Settings > Logging screen.
3.	 Click Refresh List.
4.	 In the Log File Management window, select the file to save.
5.	 Click Save Selected to save the file to a folder on your computer.
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